Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Laptop getting worse FPS in game using own screen than monitor

Sorry if this isn't in the right place, but I have a strange problem and I wanted to see if anyone could shed light on this. I was at my friend's house trying to record a game of Minecraft on my laptop. The laptop is a Dell Inspiron 15-7000 gaming. It has a core i7 7700HQ, a 1050ti, 32GB of ram and a 1080p 60hz screen. I turned on Chocapic shaders to film a certain type of video and all of a sudden, the laptop can't seem to handle it as it dropped down to 8 FPS. I've run these shaders before with 40-50fps no problem. Running Bandicam or not doesn't seem to affect it in the slightest. So about a week later, I plugged it up to a very large screen I have at my house so we could lan party because his house had lost power. I decided to give the shaders a try again and I was getting 50 or so FPS (Laptop screen closed). No settings have been changed in the least. So Once his power came back on, I shut the laptop down and brought it with me over to his house. Once there, I tried it again because I was going to go ahead and record the video, but 8FPS happened again only using the laptop screen. Why does the laptop put out way more FPS than the laptop screen? Shouldn't it be the complete opposite? Mine you, I instead played Conan Exiles on 1080p with mostly epic and high graphics and 4x AA getting 50-80 FPS at any given time with just the laptop screen. Any insight into this issue would be appreciated.

Link to post
Share on other sites

Sounds like MC is running on the iGPU instead of the dedicated graphics card. When you plug in the external monitor it's forced to run on the dGPU since the monitor is connected to it.

 

So check the Windows power plan is set to performance and that MC is set to use the high performance GPU.

F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB SX8200Pro, 2x16TB Ironwolf RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary, Mountain Everest Max

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB SX8200Pro RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites
8 minutes ago, Kilrah said:

Sounds like MC is running on the iGPU instead of the dedicated graphics card. When you plug in the external monitor it's forced to run on the dGPU since the monitor is connected to it.

 

So check the Windows power plan is set to performance and that MC is set to use the high performance GPU.

I see that you're right when looking at the task manager running the game, but when I go to Nvidia control panel, it says Minecraft and all MC related things are supposed to be running on Nvidia processor. Is there a setting I'm missing or is something amiss?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×