Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Mouse wont click unless I go into CTRL + Alt+ Delete

So I am having this weird issue where my mouse (or any other mouse I use on this PC for that matter) will not click in certain windows. There are times where I cant click ANYTHING in Discord, but I can in chrome, also cant click anything on taskbar. BUT if I go into CTRL + Alt+ Delete, I can go and move my mouse over the options and then click cancel and then my mouse starts to work again. I have tried different ports, and different mice, unplugged Keyboard and others and tried to use it and it not work WHATSOEVER but when I hit CTRL + Alt + Del it will magically work again for a little bit. No Idea what is causing this issue or how to permanently fix it, hoping you guys/gals will have more info on how I could fix this issue permanently. Because it is now starting to effect work since I work from home.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×