Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Discord using NVIDIA GPU

Go to solution Solved by PorkishPig,
4 minutes ago, stonowinnerz said:

Then I added Discord here to be used only by iGPU but I can't get to work. Well, I can until I turn on my camera in Discord.

Disable "OpenH264 Video Codec provided by Cisco Systems, Inc." under Settings > Voice & Video.

Hello,

I've recently purchased laptop Lenovo Legion 5 Pro (Ryzen 7 5800H+3060+16GB RAM+1TB SSD,...). I'm testing the hybrid mode by Lenovo which is available in Lenovo Vantage app. It should decide which GPU should PC use for different apps (that means both GPUs are available). I have enabled in Nvidia Control Panel to show icon in tray if the 3060 is used by some application or program. In Nvidia Control Panel -> 3D settings I can see notification that in newer versions of Windows is Windows managing usage of GPUs. Okay then, I set the browser to be used by iGPU in Windows. That is working fine. Then I added Discord here to be used only by iGPU but I can't get to work. Well, I can until I turn on my camera in Discord. Then I can see that 3060 is used by proccess "discord.exe" but only after I enable the camera. After turning it off the process still remains used by 3060. Only after restarting the Discord it's used by iGPU and after turning on video 3060 takes control again. I have it set in Windows to use iGPU and also I tried to set it in Nvidia Control Panel (despite the notification that Windows is managing it) but no change. I tried turning off Hardware Acceleration in Discord but no change. Any idea why 3060 takes control of Discord after turning on my camera(video)?

 

Thanks! 🙂

Link to post
Share on other sites
Posted (edited)
4 minutes ago, stonowinnerz said:

Then I added Discord here to be used only by iGPU but I can't get to work. Well, I can until I turn on my camera in Discord.

Disable "OpenH264 Video Codec provided by Cisco Systems, Inc." under Settings > Voice & Video.

Edited by PorkishPig

Make sure to quote me or use @PorkishPig to notify me that you replied!

 

 

Desktop

CPU - Ryzen 9 3900X | Cooler - Noctua NH-D15 | Motherboard - ASUS TUF X570-PLUS RAM - Corsair Vengeance LPX DDR4-3200 16GB (2x8) Case - Meshify C

GPU - RTX 3080 FE PSU - Straight Power 11 850W Platinum Storage - 960 EVO 500GB, S31 1TB, MX500 500GB | OS - Windows 10 Pro

 

Homelab

CPU - Core i5-11400 | Cooler - Noctua NH-U12S | Motherboard - ASRock Z590M-ITX RAM - G.Skill Ripjaws V DDR4-3600 32GB (2x16)  | Case - Node 304

PSU - EVGA B3 650W | Storage - 860 EVO 256GB, Sabrent Rocket 4.0 1TB, WD Red 4TB (x6 in RAIDZ1 w/ LSI 9207-8i) | OS - TrueNAS Scale (Debian)

Link to post
Share on other sites
1 minute ago, PorkishPig said:

Disable "OpenH264 Video Codec provided by Cisco Systems, Inc." under Settings > Voice & Video.

Thank you so much. Should I leave the acceleration in Settings > Advanced disabled? And I see that you have edited your answer. I disabled the option you had there before edit and it's working.

Link to post
Share on other sites
Just now, stonowinnerz said:

Thank you so much. Should I leave the acceleration in Settings > Advanced disabled? And I see that you have edited your answer. I disabled the option you had there before edit and it's working.

I believe you can keep this option enabled, as your GPU is only being used for encoding.

Make sure to quote me or use @PorkishPig to notify me that you replied!

 

 

Desktop

CPU - Ryzen 9 3900X | Cooler - Noctua NH-D15 | Motherboard - ASUS TUF X570-PLUS RAM - Corsair Vengeance LPX DDR4-3200 16GB (2x8) Case - Meshify C

GPU - RTX 3080 FE PSU - Straight Power 11 850W Platinum Storage - 960 EVO 500GB, S31 1TB, MX500 500GB | OS - Windows 10 Pro

 

Homelab

CPU - Core i5-11400 | Cooler - Noctua NH-U12S | Motherboard - ASRock Z590M-ITX RAM - G.Skill Ripjaws V DDR4-3600 32GB (2x16)  | Case - Node 304

PSU - EVGA B3 650W | Storage - 860 EVO 256GB, Sabrent Rocket 4.0 1TB, WD Red 4TB (x6 in RAIDZ1 w/ LSI 9207-8i) | OS - TrueNAS Scale (Debian)

Link to post
Share on other sites

Yes, it's working with it enabled. I just had to disable H.264 Hardware Acceleration. Thank you!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×