Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Do I have to change a setting to use the full 144hz

Go to solution Solved by tkitch,

If you've got the NVidia Control panel installed, it may override and disable the default windows settings.

 

Right-Click on Desktop -->  NVidia Control Panel

 

image.png.04d01088d8b406444d27c1c5cb4b8f9f.png

I had a 60hz monitor before but just got a 144hz. But I notice no difference  whatsoever, is there something that I have to change? I'm probably just really dumb

Link to post
Share on other sites

most of the time your gpu would set it to the right refresh rate

if not, you may check it in: right click desktop -> display settings -> advanced display settings (scroll way down) -> image.png.2dc18ffe83fb5470fa7739afe11da145.png 

 

though you may not see a difference because your games may not be running at high enough fps to leverage the extra hz

or you're not that sensitive to it and may take some getting used to

My PCs: Desky | Beddie | Miney | Benchie

Things I need help with: (nothing at the moment)

Spoiler

none atm

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

Spoiler

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

Personal Blacklisted Companies:

Spoiler

Acer: shit tier quality products, shit tier customer service thus far, they "tried" to solve my issue but they arent really doing anything but delaying and delaying. (on-going case since July)

Gigabyte: horrible customer service (gigabyte had literally 0 customer service, asked me to go to retailer with NO WAY to email them about a question) but at least they fixed my shit in ONE MONTH (would probably take me 1 hour to fix if they let me email them)

XiaoMi Phones: built like a tank but the software is buggy as all hell

Seagate HDD: had too many dead seagate drives

Kingston SSD: 300V controller swap thingy

Razer (except their mouse)

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

 

Link to post
Share on other sites

What's your GPU?

 

Also, how is the monitor connected

Link to post
Share on other sites
3 minutes ago, SquiddyButler said:

I had a 60hz monitor before but just got a 144hz. But I notice no difference  whatsoever, is there something that I have to change? I'm probably just really dumb

Open settings, click System, click display, scroll to where it says advanced settings at the bottom, click that, and there should be a little drop down box you can click to change it.

saying graphic card is the funniest thing in the world

Probably the best and most in depth PC build guide, great for beginners https://www.youtube.com/watch?v=dQw4w9WgXcQ

⬇️ Specs Below⬇️ 

 

CPU: Ryzen 3 2200G@3.5GHz

COOLER: AMD Wraith Stealth Cooler

GPU: Uh.. imagine having one of those, cringe

MOBO: Gigabyte A320M-S2H

MEMORY: 16 GB OLOy DDR4@3200 (2x8GB)

STORAGE: Kingston A400, 240 GB

PSU: ARESGAME AGV500 (500 WATT)

CASE: MONTECH Flyer, Black

 

Link to post
Share on other sites

If you've got the NVidia Control panel installed, it may override and disable the default windows settings.

 

Right-Click on Desktop -->  NVidia Control Panel

 

image.png.04d01088d8b406444d27c1c5cb4b8f9f.png

Link to post
Share on other sites
7 minutes ago, Cool_Evlo said:

Open settings, click System, click display, scroll to where it says advanced settings at the bottom, click that, and there should be a little drop down box you can click to change it.

Thank you

Link to post
Share on other sites
9 minutes ago, tkitch said:

What's your GPU?

 

Also, how is the monitor connected

Zotac 3070 Amp holo, and via display port

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×