Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Toshiba Equium not POSTing

I was using an old Toshiba Equium laptop as a DVR for a security cameras. This weekend I was going to tidy up my Television area as it was very messy! I unplugged everything and when I got to the laptop it suddenly shut down (before I touched it). then once I came back to plug it back in I pressed the on button and nothing happens, I tried again and accidentally hit the internet button and it fired up! and after a few second the fans turned off and the lights turned off so I tried replacing the ram and that did nothing. after that I ran out of things to try, could people post suggestions!

 

in summary it only turns on when you press the internet button, once it comes on it shuts back off immediately!

 

hope you can help!

Link to post
Share on other sites

Probably a short somewhere in there.

Link to post
Share on other sites

Merged, please don't repost topics.

F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB NVMe SSD, 2x16TB HDD RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB NVMe SSD RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to post
Share on other sites
  • 2 weeks later...
On 5/9/2021 at 12:37 PM, PineyCreek said:

Probably a short somewhere in there.

It turned on for about half an hour and then shut off and continued to do the same thing

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×