Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC Shutting Down When Launching Warzone/Fortnite

I have a friend whos PC just shuts down when he goes to launch Warzone and Fortnite. He can play rocket league perfectly fine. He has replaced PSU, and GPU. He doesn't know where else to look his temps are fine. Recently replaced MB and CPU. 

Specs:

Ryzen 5 5600X

Radeon 6800 XT

Corsair Vengence RGB 16 GB

ASUS Rog strix B550 

NZXT X53

NZXT 750W Gold 

 

Link to post
Share on other sites

Is he running overclocks, has he reverified his files/reinstalled the games, what do his temps look like?

Link to post
Share on other sites
3 minutes ago, RAM555789 said:

Is he running overclocks, has he reverified his files/reinstalled the games, what do his temps look like?

He hasnt overclocked, he reinstalled the games. His temps for cpu are around 40 and gpu is like 50 and as soon as he presses launch on warzone through battle net it just shuts it down

Link to post
Share on other sites

Also when he stress tests it, it goes through with them perfectly fine and doesnt shut down.

 

Link to post
Share on other sites

is he using one pcie power cable for the gpu you cant use the dasiy chaines you have to use 2 seperate power cables the power cable only support 150w and it needs 300w this is why its shutting down the power supply is going into over load protection and shutting down 

Link to post
Share on other sites
5 hours ago, keysbeast said:

is he using one pcie power cable for the gpu you cant use the dasiy chaines you have to use 2 seperate power cables the power cable only support 150w and it needs 300w this is why its shutting down the power supply is going into over load protection and shutting down 

I will check with him when he wakes up, but if it makes a difference he also had a 1080 prior to the 6800XT and it was still doing it with that.

Link to post
Share on other sites
5 hours ago, RitualBZ said:

I will check with him when he wakes up, but if it makes a difference he also had a 1080 prior to the 6800XT and it was still doing it with that.

Did he DDU his drivers and reinstall them after the switch?

Link to post
Share on other sites
6 hours ago, RitualBZ said:

I will check with him when he wakes up, but if it makes a difference he also had a 1080 prior to the 6800XT and it was still doing it with that.

it really sounds like a power supply problem to me 

Link to post
Share on other sites
1 hour ago, keysbeast said:

it really sounds like a power supply problem to me 

He had a 600W before with his 1080 and it was originally working then all of the sudden it started to restart when launching those games. He then upgraded to the 750W and its still doing it. Hes going to try the 2 separate power cables rn

Link to post
Share on other sites
1 hour ago, RAM555789 said:

Did he DDU his drivers and reinstall them after the switch?

He did before switching after switching he just installed the latest. Ill have him DDU his driver and fresh install them

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×