Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

GPU goes blackscreen when playing games

so recently i send in my Asus Dual RX 580 4GB back to Asus for RMA and it cam back as 8GB version (Neat) but when I installed it on my upgraded system (Now Ryzen 3 3300X, MSI B550 Tomahawk, Seasonic Focus GX850) it went black screen, I have to completely cut the power to get it to display, when i just pressed the reset buton the motherboard's debug LED will stop at VGA
i already send in for another RMA again (in less than a week lol)
but could it be some other parts is broken? (I haven't updated my build list and signature yet so ask me if you want to know all the spec)

Current PC Spec
CPU: AMD Ryzen 3 3300X 4C8T 
CPU Cooler: Scythe Mugen 5
Motherboard: MSI B450 Gaming Plus MAX
RAM: Adata XPG D50 DDR4 3200 CL16 (XMP)
GPU: Asus Dual RX 580 O4G
Storages: 1x500GB Kingston A2000 M.2 NVME(boot drive) 1X1TB Adata SU800 Ultiamte 2.5 inch Sata3 SSD(Game storage) 1X1TB WD Blue 7200 RPM 3.5 inch Hard drive(game and mass storage)
Case: Montech Air 900 Mesh Mid-Tower ATX case
PSU: Delta GPS-500EB 80+ Bronze Non-Modular power supply
Case Fans: 4X Cooler Master SickleFlow 120 RGB fan, 2x 140mm Cooler Master A14-025

Keyboard: Ducky Zero 3108 Cherry MX red
Mouse: Logitech G603 LightSpeed
Headphone: Audio-Technica ATH-M20x
Microphone: AVerMedia AM310

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×