Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

New PC not able to use my home internet.

How is the rest of the system performance? [navigating through the folders, playing a game, opening programs]

PSU Tier List      AMD Motherboard Tier List      SSD Tier List

If I helped you out, please leave a thumbs up. It's appreciated.

If your issue is resolved, please share the fix with the community.

 

Link to post
Share on other sites
25 minutes ago, Tech87 said:

How is the rest of the system performance? [navigating through the folders, playing a game, opening programs]

Its cant even download steam setup and its a 1700kb download. The download time kept going up and now it wont even complete.

Link to post
Share on other sites

Alright, update on my network. I replaced my xfinity gateway with a netgear C7100v modem router combo. I set it all up and am now able to use the internet as I need. However, download speeds are super slow sitting at about 70 mbps when I check on xfinity speed test. For reference the laptop downstairs is connected by ethernet as well and reported 500 mbs on the same speed test. I tried swapping my PC's ethernet port in the modem but no luck.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×