Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Random disconnect for 1-3sec issue with wireless mouse

I have a corsair harpoon rgb wireless mouse. I have tried different usb ports and turn off everything that would allow the usb power to torn off. I was just working fine a week ago. while connect via cord, everything seems fine, but when I use wireless, the usb randomly disconnects and then reconnect after 1-3secs. Anyone can tell me if there's a fix for this? thank you.

Link to post
Share on other sites

usbextaa6bk_main.jpg.160f397a3bdb725f9b17356d6d88c62d.jpg

 

i have signal problems with my BT and mouse USB dongle's so i got some of these USB extensions, and routed my back usb ports around my desk with them.

if you test line of sight/range you could confirm a signal issue.

otherwise it could be the battery?

lastly have you performed Percussive-maintenance? and accidently loosened a wire inside perhaps?

Link to post
Share on other sites

I tried with a usb extender, front io and direct from the back of mobo. As for the signal issue, just tried and check for interference, it shouldn't be it. It should also be the batteries as it's built in and that thing is this most of the time happens when I'm playing a game. I'm currently thinking of possible 3 possible issue. 1st is the dongle itself has an issue as when I'm directly connected via usb, the mouse works fine. 2nd usb interference/driver issue, because it happened before with other devices, just more rare than now. 3rd, would be the bios or mobo, I remember 2 weeks ago we had power interruption  a few times just for few seconds and somethings minutes, and the person who used the pc then said that the pc did not boot and went back from optimized settings to turn back on. I've kept  pushing the date to check the settings on bios because the pc was "working fine" until I forgot it happened and only now remembered. hahaha

 

as for the loose wirings and Percussive-maintenance, I'll do it now before I check the bios. Hope this works, I don't want to send this mouse back only to find out it was not the issue. Thank you.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×