Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Hello everyone, it's my first time when im writing here,my english is not my first language so sorry for mistakes.

I have a laptop. Asus GL502VMK. CPU is Intel i7-7700HQ. It's base frequency is 2.8GHz while Boosted it should be 3.8.

I started gaming and game was running very poorly so i checked how my CPU is doing through this program.

I have no clue why this is happening right now. What could possibly cause this issue? Thank you for the help.

sudas.jpg

Link to post
Share on other sites

just check its speed is the task manager while you have it loaded

Link to post
Share on other sites
3 minutes ago, emosun said:

just check its speed is the task manager while you have it loaded

It doesn't go above 2.8Ghz.

Link to post
Share on other sites

Don't know if this would help but I had the same problem after updating Windows to the newest version. Some cumulative updates down the line eventually fixed that.

Link to post
Share on other sites

Boost is not constant by Intel's spec, it's allowed to run for up to 56 seconds, and there's a whole lot of conditions to that like thermals, how many cores are being utilized, etc. When doing something for long periods of time, like playing a game, you're always going to be mostly running at the base clock.

 

CPU: AMD Ryzen 9 5900X · Cooler: Artic Liquid Freezer II 280 · Motherboard: MSI MEG X570 Unify · RAM: G.skill Ripjaws V 2x16GB 3600MHz CL16 (2Rx8) · Graphics Card: ASUS GeForce RTX 3060 Ti TUF Gaming · Boot Drive: 500GB WD Black SN750 M.2 NVMe SSD · Game Drive: 2TB Crucial MX500 SATA SSD · PSU: Corsair White RM850x 850W 80+ Gold · Case: Corsair 4000D Airflow · Monitor: MSI Optix MAG342CQR 34” UWQHD 3440x1440 144Hz · Keyboard: Corsair K100 RGB Optical-Mechanical Gaming Keyboard (OPX Switch) · Mouse: Corsair Ironclaw RGB Wireless Gaming Mouse

Link to post
Share on other sites
1 minute ago, Chris Pratt said:

Boost is not constant by Intel's spec, it's allowed to run for up to 56 seconds, and there's a whole lot of conditions to that like thermals, how many cores are being utilized, etc. When doing something for long periods of time, like playing a game, you're always going to be mostly running at the base clock.

 

Before this happened in task manager in Performance tab it showed that CPU speed was 3.4.GHz .

Link to post
Share on other sites
21 minutes ago, MonkiWoltas said:

Before this happened in task manager in Performance tab it showed that CPU speed was 3.4.GHz .

It may have been at the time of measurement. Again, the chip will boost as long as it's allowed to and has not already hit its boost expiry. This is the way all CPUs work, Intel and AMD. The boost speed is not something you get all the time. It does help make the CPU faster for short term tasks, and for day to day usage, that overall gives you a better experience, but it's not the number you pay attention to for things like gaming or long running tasks. That's all going to be base clock.

CPU: AMD Ryzen 9 5900X · Cooler: Artic Liquid Freezer II 280 · Motherboard: MSI MEG X570 Unify · RAM: G.skill Ripjaws V 2x16GB 3600MHz CL16 (2Rx8) · Graphics Card: ASUS GeForce RTX 3060 Ti TUF Gaming · Boot Drive: 500GB WD Black SN750 M.2 NVMe SSD · Game Drive: 2TB Crucial MX500 SATA SSD · PSU: Corsair White RM850x 850W 80+ Gold · Case: Corsair 4000D Airflow · Monitor: MSI Optix MAG342CQR 34” UWQHD 3440x1440 144Hz · Keyboard: Corsair K100 RGB Optical-Mechanical Gaming Keyboard (OPX Switch) · Mouse: Corsair Ironclaw RGB Wireless Gaming Mouse

Link to post
Share on other sites
1 hour ago, Chris Pratt said:

It may have been at the time of measurement. Again, the chip will boost as long as it's allowed to and has not already hit its boost expiry. This is the way all CPUs work, Intel and AMD. The boost speed is not something you get all the time. It does help make the CPU faster for short term tasks, and for day to day usage, that overall gives you a better experience, but it's not the number you pay attention to for things like gaming or long running tasks. That's all going to be base clock.

It was all the time 3.4GHz no matter what i was doing and i saw significantly performance decrease while gaming. 😔

Link to post
Share on other sites
1 hour ago, MonkiWoltas said:

It was all the time 3.4GHz no matter what i was doing and i saw significantly performance decrease while gaming. 😔

Well, especially in a laptop, the thermal profile changes drastically when gaming because of the increased power going into the GPU, meaning even less opportunity for boost. Again, this is *normal*. You're not going to see boost clocks when gaming.

CPU: AMD Ryzen 9 5900X · Cooler: Artic Liquid Freezer II 280 · Motherboard: MSI MEG X570 Unify · RAM: G.skill Ripjaws V 2x16GB 3600MHz CL16 (2Rx8) · Graphics Card: ASUS GeForce RTX 3060 Ti TUF Gaming · Boot Drive: 500GB WD Black SN750 M.2 NVMe SSD · Game Drive: 2TB Crucial MX500 SATA SSD · PSU: Corsair White RM850x 850W 80+ Gold · Case: Corsair 4000D Airflow · Monitor: MSI Optix MAG342CQR 34” UWQHD 3440x1440 144Hz · Keyboard: Corsair K100 RGB Optical-Mechanical Gaming Keyboard (OPX Switch) · Mouse: Corsair Ironclaw RGB Wireless Gaming Mouse

Link to post
Share on other sites
7 hours ago, MonkiWoltas said:

It doesn't go above 2.8Ghz.

Intel Turbo Boost is disabled. Run ThrottleStop and post some screenshots.

https://www.techpowerup.com/download/techpowerup-throttlestop/

 

Run a test like Cinebench R20 and watch your CPU speed.

https://www.techpowerup.com/download/maxon-cinebench/

 

Does it ever go over 2.8 GHz? Open Limit Reasons and show me a picture if any boxes are red in that window while the CPU is loaded. Make sure Disable Turbo is not checked.

 

Some update might have set the turbo power limits incorrectly. This can disable Intel Turbo Boost. Show me a screenshot of the ThrottleStop - TPL window so I can see how your power limits are set. Also check the FIVR - Disable and Lock Turbo Power Limits option in ThrottleStop.

 

Link to post
Share on other sites
19 hours ago, unclewebb said:

Intel Turbo Boost is disabled. Run ThrottleStop and post some screenshots.

https://www.techpowerup.com/download/techpowerup-throttlestop/

 

Run a test like Cinebench R20 and watch your CPU speed.

https://www.techpowerup.com/download/maxon-cinebench/

 

Does it ever go over 2.8 GHz? Open Limit Reasons and show me a picture if any boxes are red in that window while the CPU is loaded. Make sure Disable Turbo is not checked.

 

Some update might have set the turbo power limits incorrectly. This can disable Intel Turbo Boost. Show me a screenshot of the ThrottleStop - TPL window so I can see how your power limits are set. Also check the FIVR - Disable and Lock Turbo Power Limits option in ThrottleStop.

 

Like this one?

jega.jpg

Link to post
Share on other sites

@MonkiWoltas Intel 7th Generation CPUs like you have can use Speed Shift Technology (SST). Some laptops did not enable SST in the BIOS like they should have been doing. This feature allows the CPU to efficiently control its speed. All laptops run best when Speed Shift is enabled.

 

Push the TPL button to open the Turbo Power Limits window. Check the Speed Shift option and press the Apply button. After you press Apply it should tell you at the top of the column what the appropriate Min and Max values are. For a 7700HQ, Speed Shift Max should be set to 38. That is the maximum CPU multiplier a 7700HQ can use when turbo boost is enabled.

 

image.png.6885dba30a91fbc37685756338a418b6.png

 

Now press OK and go back out to the main screen. You should see SST in green which confirms that Speed Shift Technology is enabled.  

 

image.png.27396d28623677157fff10fd2353e81e.png

 

Now you can check the Speed Shift - EPP box. The EPP value tells the CPU how much turbo boost the CPU should use. Where it says 128, you can click on that number and edit it. Setting EPP = 0 tells the CPU to use maximum speed all of the time whether the CPU is fully loaded or lightly loaded. This is a good setting for desktop computers that are plugged in. 

 

Setting EPP = 80 is a good value for most laptops. This allows the CPU to slow down when lightly loaded.

 

Setting EPP = 128 or higher is OK when running on battery power. You can set the EPP value to whatever value you like. There is no right or wrong value. It is up to you to decide. You can setup two different profiles in ThrottleStop so it automatically changes the EPP value when you unplug or plug your computer in.

 

When Speed Shift is set up properly, your CPU will finally be able to run at the proper speed. There might have been a problem with a recent Windows update. That is why your CPU is not using turbo boost. When you get this fixed, try running a TS Bench - 1 Thread test. Post a screenshot of ThrottleStop while that test is running. This test should show a high multiplier and lots of turbo boost. 

 

Link to post
Share on other sites
29 minutes ago, unclewebb said:

@MonkiWoltas Intel 7th Generation CPUs like you have can use Speed Shift Technology (SST). Some laptops did not enable SST in the BIOS like they should have been doing. This feature allows the CPU to efficiently control its speed. All laptops run best when Speed Shift is enabled.

 

Push the TPL button to open the Turbo Power Limits window. Check the Speed Shift option and press the Apply button. After you press Apply it should tell you at the top of the column what the appropriate Min and Max values are. For a 7700HQ, Speed Shift Max should be set to 38. That is the maximum CPU multiplier a 7700HQ can use when turbo boost is enabled.

 

image.png.6885dba30a91fbc37685756338a418b6.png

 

Now press OK and go back out to the main screen. You should see SST in green which confirms that Speed Shift Technology is enabled.  

 

image.png.27396d28623677157fff10fd2353e81e.png

 

Now you can check the Speed Shift - EPP box. The EPP value tells the CPU how much turbo boost the CPU should use. Where it says 128, you can click on that number and edit it. Setting EPP = 0 tells the CPU to use maximum speed all of the time whether the CPU is fully loaded or lightly loaded. This is a good setting for desktop computers that are plugged in. 

 

Setting EPP = 80 is a good value for most laptops. This allows the CPU to slow down when lightly loaded.

 

Setting EPP = 128 or higher is OK when running on battery power. You can set the EPP value to whatever value you like. There is no right or wrong value. It is up to you to decide. You can setup two different profiles in ThrottleStop so it automatically changes the EPP value when you unplug or plug your computer in.

 

When Speed Shift is set up properly, your CPU will finally be able to run at the proper speed. There might have been a problem with a recent Windows update. That is why your CPU is not using turbo boost. When you get this fixed, try running a TS Bench - 1 Thread test. Post a screenshot of ThrottleStop while that test is running. This test should show a high multiplier and lots of turbo boost. 

 

It's while running,also i noticed that Value and Max in Open Hardware Monitor program is higher than it was before.

jega3.jpg

jega55.jpg

Link to post
Share on other sites
25 minutes ago, MonkiWoltas said:

Value and Max in Open Hardware Monitor program is higher

Your computer is using Intel turbo boost so it is running faster.

 

When your computer is idle, press the C10 button and open the C States window. If you disabled the C states in the BIOS, your computer will not be able to use the maximum turbo boost multiplier. If the three columns; C3%, C6% and C7% all show 0.0, you need to go into the BIOS and make sure C states are enabled. Intel's locked CPUs like you have need the C states enabled so they can use the maximum turbo multiplier (38).

 

My computer uses core C7 when it is idle.

 

image.png.0e9f8c59e988a900c44c53a4c3c6d62e.png

 

Link to post
Share on other sites
31 minutes ago, unclewebb said:

Your computer is using Intel turbo boost so it is running faster.

 

When your computer is idle, press the C10 button and open the C States window. If you disabled the C states in the BIOS, your computer will not be able to use the maximum turbo boost multiplier. If the three columns; C3%, C6% and C7% all show 0.0, you need to go into the BIOS and make sure C states are enabled. Intel's locked CPUs like you have need the C states enabled so they can use the maximum turbo multiplier (38).

 

My computer uses core C7 when it is idle.

 

image.png.0e9f8c59e988a900c44c53a4c3c6d62e.png

 

I tried to find these settings in BIOS but i couldn't , only few options there is , nothing with CPU .

Link to post
Share on other sites

@MonkiWoltas Open the ThrottleStop C states window. Are your C states working when idle? Post a picture of the C States window when your computer is idle.

 

Turbo boost is not fully working so I think all of the C states are disabled.

Link to post
Share on other sites
1 minute ago, unclewebb said:

@MonkiWoltas Open the ThrottleStop C states window. Are your C states working when idle? Post a picture of that window. 

 

Turbo boost is not fully working so I think the C states are disabled.

 

empti.jpg

Link to post
Share on other sites

Your C states are not working. That will make your laptop run hot and that is why your CPU is not using full turbo boost. There is usually a setting for this in the BIOS. Post some screenshots of your BIOS settings.

 

When the C states are disabled, the maximum CPU speed is 3400 MHz. When C states are enabled, the CPU can run as fast as 3800 MHz when 1 core is active.

 

https://www.cpu-world.com/CPUs/Core_i7/Intel-Core i7 i7-7700HQ.html

 

Link to post
Share on other sites
10 minutes ago, unclewebb said:

Your C states are not working. That will make your laptop run hot and that is why your CPU is not using full turbo boost. There is usually a setting for this in the BIOS. Post some screenshots of your BIOS settings.

 

When the C states are disabled, the maximum CPU speed is 3400 MHz. When C states are enabled, the CPU can run as fast as 3800 MHz when 1 core is active.

 

https://www.cpu-world.com/CPUs/Core_i7/Intel-Core i7 i7-7700HQ.html

 

Sorry for the quality of pictures.

IMG_20210331_182626.jpg

IMG_20210331_182705.jpg

Link to post
Share on other sites

@MonkiWoltas You are right. Your Asus laptop does not have many options available in the BIOS.

 

Some laptop manufacturers deliberately disabled the C states. This might be a setting in the BIOS that Asus has hidden. This means your CPU will run hotter when idle and it will not be able to use the full 38 multiplier. I have seen other gaming laptops with similar problems. 

 

At least your CPU can use the 34 multiplier now that Speed Shift is enabled. That is not perfect but it is better than before. 

 

You can try using ThrottleStop to switch to different Windows power plans. Put a check mark in the box beside High Performance at the top left of the main window. Set this to High Performance, Balanced and then Power Saver and watch the C states window when idle to see if a different power plan makes the C States work. If they still do not work, set this back to High Performance or Balanced and then you can clear the check mark beside this box.

 

If you cannot get the C states working then there is nothing else you can do to go faster. 

Link to post
Share on other sites
14 minutes ago, unclewebb said:

@MonkiWoltas You are right. Your Asus laptop does not have many options available in the BIOS.

 

Some laptop manufacturers deliberately disabled the C states. This might be a setting in the BIOS that Asus has hidden. This means your CPU will run hotter when idle and it will not be able to use the full 38 multiplier. I have seen other gaming laptops with similar problems. 

 

At least your CPU can use the 34 multiplier now that Speed Shift is enabled. That is not perfect but it is better than before. 

 

You can try using ThrottleStop to switch to different Windows power plans. Put a check mark in the box beside High Performance at the top left of the main window. Set this to High Performance, Balanced and then Power Saver and watch the C states window when idle to see if a different power plan makes the C States work. If they still do not work, set this back to High Performance or Balanced and then you can clear the check mark beside this box.

 

If you cannot get the C states working then there is nothing else you can do to go faster. 

It still shows 0.0 everywhere ,anyway that's still better than anything! Thank you very much for your help!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×