Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Lagging but I have a nice pc

Hello everyone, 

 

This is my pc here

 

I've been playing League of Legends and other games when I feel like sometimes I get 60 fps when I should get +144.

 

People told me that the issue might be in the monitors. I have 2 of them, the AOC and a really old one +10 years old, the 1704 PVT , I can't even find a website with its information.

 

Can someone help me ?

Link to post
Share on other sites

Do you get 60fps some of the time, or all the time?

Link to post
Share on other sites
Just now, Avanta8 said:

Do you get 60fps some of the time, or all the time?

I get this really laggy gameplay 50-70 fps frames drops. 

Link to post
Share on other sites
10 minutes ago, yMaths said:

Hello everyone, 

 

This is my pc here

 

I've been playing League of Legends and other games when I feel like sometimes I get 60 fps when I should get +144.

 

People told me that the issue might be in the monitors. I have 2 of them, the AOC and a really old one +10 years old, the 1704 PVT , I can't even find a website with its information.

 

Can someone help me ?

I seriously doubt its the monitors. Make sure your GPU drivers are updated. Make sure your RAM is running in XMP and dual channel. Are your temps okay?

Also you could try reinstalling the game

geometry is hard
b550 > x570

Link to post
Share on other sites
1 minute ago, yMaths said:

I get this really laggy gameplay 50-70 fps frames drops. 

So what fps do you average?

Link to post
Share on other sites
Just now, Downkey said:

I seriously doubt its the monitors. Make sure your GPU drivers are updated. Make sure your RAM is running in XMP and dual channel. Are your temps okay?

Also you could try reinstalling the game

Sorry for bothering you with easy questions but..

 

My GHP drivers are updated, did it last week;

My RAM is on dual channel but whats XMP ?

My temps are fine and also when I am playing it uses 30% of CPU and 50% CPU nothing too much but it stills get laggy.

Link to post
Share on other sites
1 minute ago, Avanta8 said:

So what fps do you average?

less then 60 fps prob 55 fps

Link to post
Share on other sites
1 minute ago, yMaths said:

Sorry for bothering you with easy questions but..

 

My GHP drivers are updated, did it last week;

My RAM is on dual channel but whats XMP ?

My temps are fine and also when I am playing it uses 30% of CPU and 50% CPU nothing too much but it stills get laggy.

XMP - Xtreme Memory Profile. What speed is your RAM running at?

geometry is hard
b550 > x570

Link to post
Share on other sites
Just now, yMaths said:

less then 60 fps prob 55 fps

I don't get what you mean then. You say you're dropping by 50 - 70 fps, but then you only average 60?

Link to post
Share on other sites
1 minute ago, Avanta8 said:

I don't get what you mean then. You say you're dropping by 50 - 70 fps, but then you only average 60?

I get 60 fps then I get frames drop to 50 fps and its lagging and unplayble

Link to post
Share on other sites

Have you checked your display setting in windows and do you have v sync turned off? I may be wrong but if windows thinks the monitor is only 60Hz which it can default to on higher monitors and the v sync is turned on in the game this may limit your max fps to 60.

 

Link to post
Share on other sites
1 minute ago, Rameares said:

Have you checked your display setting in windows and do you have v sync turned off? I may be wrong but if windows thinks the monitor is only 60Hz which it can default to on higher monitors and the v sync is turned on in the game this may limit your max fps to 60.

 

On thing I forgot to tell, I only lag when I stream on discord. I ve checked that and its fine but the old monitor doesnt have v sync

 

 

Link to post
Share on other sites
6 minutes ago, Downkey said:

XMP - Xtreme Memory Profile. What speed is your RAM running at?

2133 MHz

 

Link to post
Share on other sites
Just now, yMaths said:

2133 MHz

 

enable XMP. The RAM you bought should be running at 3200MHZ with XMP enabled.

geometry is hard
b550 > x570

Link to post
Share on other sites
Just now, yMaths said:

2133 MHz

 

That is almost definitely the issue. Enable XMP in the bios. If you don’t know how, just search on youtube “enable bios gigabyte”

Link to post
Share on other sites
2 minutes ago, curiousmind34 said:

That is almost definitely the issue. Enable XMP in the bios. If you don’t know how, just search on youtube “enable bios gigabyte”

is it safe to enable that ?

Link to post
Share on other sites
6 minutes ago, Downkey said:

enable XMP. The RAM you bought should be running at 3200MHZ with XMP enabled.

Is it safe or it can damage my pc ?

Link to post
Share on other sites
Just now, yMaths said:

is it safe to enable that ?

yes. 101% safe. Almost everyone does it.

geometry is hard
b550 > x570

Link to post
Share on other sites
Just now, Downkey said:

yes. 101% safe.

thx dude

Link to post
Share on other sites
9 minutes ago, curiousmind34 said:

That is almost definitely the issue. Enable XMP in the bios. If you don’t know how, just search on youtube “enable bios gigabyte”

Enabling XMP isn't magically going to turn 60 fps into 200.

Link to post
Share on other sites
57 minutes ago, yMaths said:

I ve checked that and its fine but the old monitor doesnt have v sync

V-sync is a GPU feature, that limits the amount of frames to a certain level, usually 60 FPS. You must be thinking FreeSync, or G-Sync which are monitor features that sync the frames to the GPU frame pacing. Many games have V-Sync on by default (annoying in my opinion). If you are hard limited to 60FPS, this would be my suspect feature to dissable.

Link to post
Share on other sites
2 hours ago, Avanta8 said:

Enabling XMP isn't magically going to turn 60 fps into 200.

That is almost definitely *an* issue

Link to post
Share on other sites
2 hours ago, yMaths said:

On thing I forgot to tell, I only lag when I stream on discord. I ve checked that and its fine but the old monitor doesnt have v sync

 

 

I think discord is messing somehow with your FPS, try reinstalling discord since it’s super easy and no data loss, and try streaming from browser version.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×