Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

EVGA 3080 FTW3 Red Light

I heard a pop and a red light on my 3080 FTW3 and my monitors lost their video input. I have three separate power cables connected to it. Is there any thing I can do before I ship it back? It isn’t over clocked at all. I have been running this card since October and it usually runs around 68c at full load. 

 

specs

i9-9900k @locked 5ghz

gigabyte z390 auros pro

corsair RMx 1000

32g Corsair vengeance pro @3200 XMP on

corsair 350 rad

o11d with all 9 fans installed. 

 

317D6B91-C74C-4764-93BB-713E8A2EA7ED.jpeg

076F1A45-564E-4751-AF83-0E16E003FE2D.jpeg

Link to post
Share on other sites

Lots of people have had this, nothing you can do but ship it back probably.

Current System: Ryzen 7 3700X, Noctua NH L12 Ghost S1 Edition, 32GB DDR4 @ 3200MHz, MAG B550i Gaming Edge, 1TB WD SN550 NVME, SF750, RTX 3080 Founders Edition, Louqe Ghost S1

Link to post
Share on other sites

@asianbomber13 The "pop" was likely the fuse on the card for a PCIe feed (connector) blowing. Apart from de-soldering the old blown fuse and resoldering a new fuse (and before doing that ask the question: What underlying condition caused it blow?) there's little you can do.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×