Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Linux extremely high fan speed.

Go to solution Solved by jj9987,

The wiki is for Arch Linux, but it applies mostly for other distros as well.

https://wiki.archlinux.org/index.php/fan_speed_control

 

EDIT: Depending on the system, the support for managing all the fans might not be possible. Just try it out. If that doesn't work, then unless you find some other solution for your specific system/platform, you don't have a lot of options.

I'm using Ubuntu as second OS and have problems with fan speeds. Its very quite until 60 degrees but when it achieve 60 or higher fan starts spinning very fast. Is there a program or driver for changing it. For example: if any temperature higher than 45, make fan speed 1700 rpm...

Link to post
Share on other sites
1 minute ago, yigitayaz262 said:

I'm using Ubuntu as second OS and have problems with fan speeds. Its very quite until 60 degrees but when it achieve 60 or higher fan starts spinning very fast. Is there a program or driver for changing it. For example: if any temperature higher than 45, make fan speed 1700 rpm...

Which fan? Tempature of what?

Everything starts spinning at about 70% (which is loud already) at 60°C

When I give advice I use my experience and google, I know alot, but not everything.

Have a question? - quote me = I'll respond either instantly or within a day or 2

Specs I have experience with: (highlited build is being used)

Pentium G4500 | 4GB/8GB DDR4 2133Mhz | H110 | GTX 1050

Ryzen 3 1200 3,5Ghz / OC:4Ghz | 8GB DDR4 2133Mhz / 16GB 3000Mhz | B450 | GTX 1050

Link to post
Share on other sites
4 minutes ago, podkall said:

Which fan? Tempature of what?

Everything starts spinning at about 70% (which is loud already) at 60°C

All fans starting loudly when any temperature higher than 60 C

Link to post
Share on other sites
Just now, yigitayaz262 said:

All fans starting loudly when any temperature higher than 60 C

yes, that's how the fancurve works, if component gets over 60 C the fans go faster

 

why do you think it's set that way?

When I give advice I use my experience and google, I know alot, but not everything.

Have a question? - quote me = I'll respond either instantly or within a day or 2

Specs I have experience with: (highlited build is being used)

Pentium G4500 | 4GB/8GB DDR4 2133Mhz | H110 | GTX 1050

Ryzen 3 1200 3,5Ghz / OC:4Ghz | 8GB DDR4 2133Mhz / 16GB 3000Mhz | B450 | GTX 1050

Link to post
Share on other sites
1 minute ago, podkall said:

yes, that's how the fancurve works, if component gets over 60 C the fans go faster

 

why do you think it's set that way?

I was need to increase fan speed when it 0-60 degrees.

Link to post
Share on other sites
1 minute ago, yigitayaz262 said:

I was need to increase fan speed when it 0-60 degrees.

What fan is spinning fast when over 60 C?

When I give advice I use my experience and google, I know alot, but not everything.

Have a question? - quote me = I'll respond either instantly or within a day or 2

Specs I have experience with: (highlited build is being used)

Pentium G4500 | 4GB/8GB DDR4 2133Mhz | H110 | GTX 1050

Ryzen 3 1200 3,5Ghz / OC:4Ghz | 8GB DDR4 2133Mhz / 16GB 3000Mhz | B450 | GTX 1050

Link to post
Share on other sites

The wiki is for Arch Linux, but it applies mostly for other distros as well.

https://wiki.archlinux.org/index.php/fan_speed_control

 

EDIT: Depending on the system, the support for managing all the fans might not be possible. Just try it out. If that doesn't work, then unless you find some other solution for your specific system/platform, you don't have a lot of options.

Skynet: MacBook Pro Late 2016 Space Gray | i7-6820HQ 2.7 GHz | 16 GB LPDDR3 | Radeon Pro 455 2048 MB | 512 GB NVMe SSD | 15" 2880x1800

HAL9000: Intel i5-9600k | Cryorig M9 | 32 GB Corsair Vengeance LPX DDR4 3200 MHz | Gigabyte Z390I AORUS PRO WIFI | MSI GTX 1080 Ti SeaHawk X | 1 TB Samsung 970 Evo Plus + 1 TB Crucial MX500 + 512 GB Samsung 970 Evo Plus | Corsair TX650M | NZXT H210i | LG 34UM95 34" 3440x1440

Hydrogen server: AMD Ryzen 9 3900x | AMD Wraith Prism | 64 GB Crucial Ballistix 3200MHz DDR4 | Asus Prime X570 Pro | Corsair HX1000 | 256 GB Samsung 850 Evo + 1 TB Crucial MX500 + 4x 3 TB + 2 TB WD Red/Seagate/Toshiba  | Fractal Design Define R5 | unRAID 6.8.3

Carbon server: Fujitsu PRIMERGY RX100 S7p | Xeon E3-1230 v2 | 16 GB DDR3 ECC | 60 GB Corsair SSD & 250 GB Samsung 850 Pro | Intel i340-T4 | ESXi 6.5.1

Big Mac cluster: 2x Raspberry Pi 2 Model B | 1x Raspberry Pi 3 Model B | 2x Raspberry Pi 3 Model B+

Link to post
Share on other sites

Also, look at your BIOS settings. It is likely your fans are controlled by the BIOS and fan curve settings are setting in a suboptimal way (considering acoustics etc). It does not make much sense to enable software fan control unless the BIOS settings are very limited and you really need it (always consider the scenario of a system hang when the processor is at a 100% usage loop - and if the fan control software doesn't work, fans will not ramp up).

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×