Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Is my GPU really that bad?

StareX
 Share

Well people tell me my GTX 560 Ti is no longer a great card.. and for my resolution I think it is.. I am running 1440x900 75Hz monitor.

 

 

Is this why I feel my games look OK.. no frame drops, but still, doesn't look that smooth? Or what? And I am running games on the highest possible graphics, and sometimes low (I'm a frames per second freak, I love dat 200fps) .. and it runs fine.. but hummm... not that, great O.o

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

It's by no means a bad card, and is a lot better than integrated like infiteybillion times... but if you're starting to notice less and less performance on newer games at high settings it might be time to upgrade.

Link to comment
Share on other sites

Link to post
Share on other sites

It's fine if it does what you need it to do. 

If you ever need help with a build, read the following before posting: http://linustechtips.com/main/topic/3061-build-plan-thread-recommendations-please-read-before-posting/
Also, make sure to quote a post or tag a member when replying or else they won't get a notification that you replied to them.

Link to comment
Share on other sites

Link to post
Share on other sites

Bad is subjective, I would've certainly upgraded a while ago, but if it meets your needs then what's the problem?

Setup Video -----------Peasant Crushing Specs----------- 4K Benchmarks


-CPU- i7 3930k @4.8GHz 1.4v -Mobo- Asus Rampage IV Extreme -GPUs- 2x GTX Titan Hydrocopper SLI -RAM- 32GB (8x4GB) Corsair Vengeance 1600MHz -Storage- 500GB Samsung 840 SSD | 2TB WD Green HDD


-Monitors- 3x BenQ XL2420T | 1x Dell U2713HM -Mouse- Steelseries Rival -Keyboard- Corsair K70 Cherry MX Brown -Headphones- Audio Techinca ATH-M50 -Microphone- RØDE NT1-A

Link to comment
Share on other sites

Link to post
Share on other sites

I also own a 560ti, but I run on 1920 x 1080 at 60Hz and to be honest I feel that it's still a great card it performs grest even in newer titles like Battlefield 4, I have no need to upgrade until the 800 series

 

CPU Intel i7-6700k | Motherboard ASUS Maximus Hero VIII | GPU MSI GTX 970 | RAM 16 GB Corsair Vengeance 3000Mhz | Cooling Noctua NH-D15 | Storage 240GB Crucial M500; 2TB Seagate Barracuda | PSU EVGA 850w | Case Phatek Enthoo Pro M Acrylic

Link to comment
Share on other sites

Link to post
Share on other sites

I mean, I don't get bad performance on newer games, chea.. I get above 60fps.. all time.. but the stuttering, and the tearing :x.. I can't breathe! :D If you know what I mean. I want a 870 or 880 Maxwell.. thought about getting a 770 or 780.. but seems like Maxwell is coming so I'll be waiting :P

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

My little brother has a 460 running a monitor at 1440x900 @ 75 and he plays most games med to high settings just fine so a 560 ti would still be a good cards for you.

Mein Führer... I CAN WALK !!

Link to comment
Share on other sites

Link to post
Share on other sites

I had a GTX560ti. After I upgraded to a 1440p monitor it couldn't handle Games like BF3 any more. I think on lower resolutions like yours and with a bit fewer details you will be ok. I upgraded mainly because of my huge monitor and for CUDA.

Link to comment
Share on other sites

Link to post
Share on other sites

I mean, I don't get bad performance on newer games, chea.. I get above 60fps.. all time.. but the stuttering, and the tearing :x.. I can't breathe! :D If you know what I mean. I want a 870 or 880 Maxwell.. thought about getting a 770 or 780.. but seems like Maxwell is coming so I'll be waiting :P

Try turning Vsync on, that might help.

I usually recommend having it off...

  • CPU
    Intel Xeon E5 2695 V3 14c-28t @ 2,8GHz
  • Motherboard
    AsRock X99 mITX
  • RAM
    2x16GB DDR4 Crucial ECC @2166MHz
  • GPU
    XFX R9 Nano 4GB HBM @1000MHz
  • Case
    Silverstone Sugo SG-13
  • Storage
    Samsung 850 EVO 500GB 
  • Intel SSD DC S3600 800GB
Link to comment
Share on other sites

Link to post
Share on other sites

I mean, I don't get bad performance on newer games, chea.. I get above 60fps.. all time.. but the stuttering, and the tearing :x.. I can't breathe! :D If you know what I mean. I want a 870 or 880 Maxwell.. thought about getting a 770 or 780.. but seems like Maxwell is coming so I'll be waiting :P

 

If you are getting 60fps at all time then there shouldnt be stuttering and tearing, at least not much, it should be really smooth - perhaps there are other issues worth addressing? cpu/ram perhaps?

Desktop - Corsair 300r i7 4770k H100i MSI 780ti 16GB Vengeance Pro 2400mhz Crucial MX100 512gb Samsung Evo 250gb 2 TB WD Green, AOC Q2770PQU 1440p 27" monitor Laptop Clevo W110er - 11.6" 768p, i5 3230m, 650m GT 2gb, OCZ vertex 4 256gb,  4gb ram, Server: Fractal Define Mini, MSI Z78-G43, Intel G3220, 8GB Corsair Vengeance, 4x 3tb WD Reds in Raid 10, Phone Oppo Reno 10x 256gb , Camera Sony A7iii

Link to comment
Share on other sites

Link to post
Share on other sites

If you are getting 60fps at all time then there shouldnt be stuttering and tearing, at least not much, it should be really smooth - perhaps there are other issues worth addressing? cpu/ram perhaps?

 

Well.. tbh, it feels like Jitter, flickering motions.. NOT "Flickering" as real real flickering.. but .. it's not THAT smooth. just looks like this: "J.a..jjajajajaja... Ja.. Ja Ja, Jajaj.. Jitter.. JzzzzZzZZZ Jazzzzzztttt" .. frame like.. dunno how to describe it more better.

Security Analyst & Tech Enthusiast

Ask me anything.

Link to comment
Share on other sites

Link to post
Share on other sites

Well.. tbh, it feels like Jitter, flickering motions.. NOT "Flickering" as real real flickering.. but .. it's not THAT smooth. just looks like this: "J.a..jjajajajaja... Ja.. Ja Ja, Jajaj.. Jitter.. JzzzzZzZZZ Jazzzzzztttt" .. frame like.. dunno how to describe it more better.

 

It shouldnt be doing that if you are getting a solid frame rate, weird

Desktop - Corsair 300r i7 4770k H100i MSI 780ti 16GB Vengeance Pro 2400mhz Crucial MX100 512gb Samsung Evo 250gb 2 TB WD Green, AOC Q2770PQU 1440p 27" monitor Laptop Clevo W110er - 11.6" 768p, i5 3230m, 650m GT 2gb, OCZ vertex 4 256gb,  4gb ram, Server: Fractal Define Mini, MSI Z78-G43, Intel G3220, 8GB Corsair Vengeance, 4x 3tb WD Reds in Raid 10, Phone Oppo Reno 10x 256gb , Camera Sony A7iii

Link to comment
Share on other sites

Link to post
Share on other sites

560? I have a gtx260 and can still run pretty much everything, not even on the lowest settings on some games like far cry 3. and all max in many games too. I play at 1080p

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×