Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Power turning on and off in my new build

This is my first time building a PC and after assembling it, I turned it on and the CPU, GPU and one case fan turns on for about 10-15 seconds until they power off again for 3 seconds and then the cycle repeats.  

These are the steps I've taken to troubleshoot:

-tried re plugging it in to power

-changing the outlet

-took it out to see if the PSU fan was running (it was)

-I ended up returning my psu and getting a new one but had the same problem.

I tried googling the issue but couldn't find any other problems matching mine.

parts list:  https://pcpartpicker.com/list/srx6LP

Link to post
Share on other sites

Have you tried your computer outside of the case? As in on the motherboard box?

 

Also ram in correct slots?

All power cables correctly connected?

 

Maybe post some pictures?

Link to post
Share on other sites
11 minutes ago, BillyPoirier said:

This is my first time building a PC and after assembling it, I turned it on and the CPU, GPU and one case fan turns on for about 10-15 seconds until they power off again for 3 seconds and then the cycle repeats.  

These are the steps I've taken to troubleshoot:

-tried re plugging it in to power

-changing the outlet

-took it out to see if the PSU fan was running (it was)

-I ended up returning my psu and getting a new one but had the same problem.

I tried googling the issue but couldn't find any other problems matching mine.

parts list:  https://pcpartpicker.com/list/srx6LP

Sounds like a bios update is needed.  B450 with ryzen 3600.  

Current Build

I5 4460

Hyper Evo 212

Gigabyte Z87X-D3H

WD 1TB HDD

XFX RX 480 RS 4GB

Thermaltake Toughpower 650w DPS RGB 80+Gold

16 Gigs ddr3 1600 Patriot Ram

Mixture of Phanteks and Thermaltake Fans

Phanteks P400S

Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×