Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Logitech Anywhere MX only partially working, thoughts?

Hi everyone. I own 2 Logitech Anywhere MX mice. I bought them both brand new at the same time several years ago, but one of them has been in storage for a little while now. I pulled it out recently to use it and saw that there was a small amount of corrosion in the battery compartment. It wasn't much at all, and I was able to clean it. However, I have a problem. I can pair it with a Unifying receiver just fine, but none of the click buttons work (left, right, middle, haven't tested the forward and back buttons yet). The scroll wheel does work fine. Any ideas? It worked perfectly fine when it was put into storage, and it still tracks perfectly fine, but obviously a mouse that can't click on anything isn't very useful. 

Main System: Phobos

AMD Ryzen 7 2700 (8C/16T), ASRock B450 Steel Legend, 16GB G.SKILL Aegis DDR4 3000MHz, AMD Radeon RX 570 4GB (XFX), 960GB Crucial M500, 2TB Seagate BarraCuda, Windows 10 Pro for Workstations/macOS Catalina

 

Secondary System: York

Intel Core i7-2600 (4C/8T), ASUS P8Z68-V/GEN3, 16GB GEIL Enhance Corsa DDR3 1600MHz, Zotac GeForce GTX 550 Ti 1GB, 240GB ADATA Ultimate SU650, Windows 10 Pro for Workstations

 

General Use Mac: Mid 2011 27" Apple iMac

Intel Core i5-2400 (4C/4T), 16GB Various DDR3 1067MHz, AMD Radeon HD 6970M 1GB, 500GB Crucial MX500, 1TB Seagate Barracuda, macOS High Sierra 10.13.6/Mac OS X Snow Leopard 10.6.8

 

Mac mini (Used as macOS server): Late 2009 Mac mini 3,1

Intel Core 2 Duo P8700 (2C/2T), 8GB DDR3 1067MHz, NVIDIA GeForce 9400 256MB, 480GB OWC Mercury Electra 3G, macOS Sierra 10.12

 

Storage Server: Clover (soon to be retired after more than a decade of reliable operation)

Intel Core 2 Duo E8500 (2C/2T), 8GB DDR2 800MHz, 160GB Western Digital Caviar SE (boot), 1TB Western Digital Caviar Blue (2x, storage), FreeNAS 11.3-U1

 

Main Laptop: Mid 2017 13" Apple MacBook Pro

Intel Core i5-7360U (2C/4T), 8GB LPDDR3 2133MHz, Intel Iris Plus 640, 128GB PCIe NVMe SSD, macOS Mojave 10.14

 

Machines below are in use on a temporary basis for Folding@home work

 

Folding Box 1: Dell OptiPlex 990 SFF

Intel Core i5-2400 (4C/4T), 16GB DDR3 1333MHz, MSI GeForce GT 710 2GB, 1TB Samsung 860 EVO, Windows 8.1 Pro

 

Folding Box 2: Lenovo ThinkCentre M73

Intel Core i5-4430 (4C/4T), 8GB DDR3 1600MHz, 500GB WD Caviar Blue, Windows 10 Pro for Workstations

 

Folding Box 3: Dell Precision Workstation T3500

Intel Xeon X5675 (6C/12T), 24GB DDR3 1333MHz, AMD Radeon HD 6870 1GB, 500GB Seagate BarraCuda, Windows 8.1 Pro

Link to post
Share on other sites

nice rig btw but I’m no expert but have you tried factory resetting it? I have 0 in mouses but yeah

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×