Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Ram not running at spec speeds?

Hello community,


I am gracefully asking for help.




I recently bought 2x 16G DDR4 2666mhz vengence LPX ram sticks to upgrade my old aurora R6. In bios I cannot acces anything in my perfomance tab and my memory is only runnung at 2133mhz. I have the base I5 7400 from intel (not overclockable). From the specs, here below, I should be able to run these speeds. What should I do?


I am just starting as a computer enthusiast and english is not my first language so sorry if I am not clear. 


Thank you in advance for all the help!




Link to post
Share on other sites

Does your motherboard support XMP?

i5 8600 - RX580 - Fractal Nano S - 1080p 144Hz

Link to post
Share on other sites

Because you cant acces the one tab in BIOS, I would try to flash it and update it to the newest version. Also before doing that you could try to clear cmos. 

Link to post
Share on other sites

NineEyeRon According to spec in the pdf I looked and shared yes!


icy330 : I checked the version of the bios and the one installed is the latest... I even reinstalled it for good measure. I'll try to clear cmos (I don't even know what it is but I am sure google can help me there!)


Thx for the time guys!


Ps Tried clearing cmos and it didn't change anything, removed MB battery and tried resetting to default in bios....



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now