Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC worked for 2years, now issues powering on, no post, acts as if 0 power is getting to mobo

Hi All,

 

Today I tried powering on my PC, and nothing happened, no LED showing on mobo, no nothing. I changed power points had the same problem, but I left it plugged in and randomly it switched on but turned off again and showed no mobo leds.

 

I took all components out of my case and tried booting with no case, same issue. I put it all back together and got power again for 5 seconds, now nothing again no mobo leds.

 

Here is what ive tried:

Shorting power switch pins

Reset CMOS

Tried my PSU in a much lower spec system i have and it worked.

Rebuilt PC on cardboard box 

Tried no gpu and 1 ram stick

 

I have also connected a different psu, only problem is it has the wrong cpu connector. (MOBO requires 8+4Pin) This psu has 4+4only (Same issues)

Specs:

Ryzen 3900x

X570 MSI Gaming Pro Carbon

Trident Z Royal 16gb

Corsair Ax850 Gold

Gigabyte 2080 Ti Modded

Meshify C case

 

Help Appreciated 🙂

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×