Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Issue with every Directx game

I have been having problems with games using direct x. Mostly playing games using dx11 and they look terrible and have "weird" physics, like characters colliding and stuttering/shaking. Ive been dealing with this for a year, i know for a fact its not my hardware because i have upgraded every single thing in my computer, monitor and keyboard/mouse controllers etc. This have been done i stages and nothing ever helped. Tried every nvidia setting and "windows tweaks" i can think of.

 

My current setup is.

 

Cpu: Intel i9 9900k

Gpu : Asus Rog Strix Rtx 2080 TI

Ram: Hyperx Predator 3200mhz 32gb ( currentrly running at 3000mhz )

SSD: 120gb ssd as boot drive and WDC Nvme 512gb as second.

MB: Asus Rog Strix z390-f

 

Im at a total loss.. Windows 10 Home , genuine copy.

Link to post
Share on other sites

I don't think DirectX would cause this. What games? Can you try reinstalling Windows and/or GPU drivers?

Quote me to see my reply!

SPECS:

CPU: Xeon X5650 OC'd to 4.2GHz @ 1.35V (courtesy of @XR6)Motherboard: Asus Sabertooth X58 RAM: 6x4GB G.Skill Ripjaws X GPU: Asus RX 570 Strix Storage: WD Blue 1TB and a 128GB Kingston UV400 PSU: EVGA 600B Case: Fractal Design Define C Cooling: H100i V2, be quiet! Pure Wings 2 (two intake, two exhausting through radiator) Monitor: 3x Dell P2210 on a Steelcase Eyesite triple monitor stand Mouse: Logitech MX Master 3 Keyboard: It changes, but usually Focus FK-9000 Mousepad: Steelseries QcK XL Headphones:  Sennheiser HD598SE and Fiio FH1S

 

 

 

 

i use arch btw

Link to post
Share on other sites

Sounds weird.. I would need to see it because what you describe... sounds wierd man. Can you upload a video?

TuringMachine

Ryzen 5 3600x - Asus Strix B450-F - Asus ROG RTX 2060S Strix AD - HyperX Predator 3200 2x8 GB DDR4 - Phanteks P400S - Corsair RM 650x - BeQuiet! Dark Rock 4 - Kingston A2000 NVMe 1TB SSD - 2x Samsung QVO 1TB SSD (RAID 0) - Seagate Barracuda 3TB

 

Quote

"If the genius of invention were to reveal tomorrow the secret of immortality, of eternal beauty and youth, for which all humanity is aching, the same inexorable agents which prevent a mass from changing suddenly its velocity would likewise resist the force of the new knowledge until time gradually modifies human thought."

  -Nikola Tesla, New York, May 16, 1907
Link to post
Share on other sites

Did you do a fresh Windows install during this time of adding upgrades ?

CPU i7 4960x Ivy Bridge Extreme | 64GB Quad DDR-3 RAM | MBD Asus x79-Deluxe | RTX 2080 ti FE 11GB |
Thermaltake 850w PWS | ASUS ROG 27" IPS 1440p | | Win 7 pro x64 |

Link to post
Share on other sites
11 minutes ago, kelvinhall05 said:

I don't think DirectX would cause this. What games? Can you try reinstalling Windows and/or GPU drivers?

Every directx game i have tried, NBA 2k19,20 and 21. Metal gear solid v, Assassins creed valhalla. I have reinstalled windows maybe 10 times, even bought another copy. Tried every driver as far back as early september 2019.

Link to post
Share on other sites

ok, this sounds like a choppy frame rate issue with full screen ?  There is some setting I remember doing with Bordered Full Screen, but should not happen with every game

CPU i7 4960x Ivy Bridge Extreme | 64GB Quad DDR-3 RAM | MBD Asus x79-Deluxe | RTX 2080 ti FE 11GB |
Thermaltake 850w PWS | ASUS ROG 27" IPS 1440p | | Win 7 pro x64 |

Link to post
Share on other sites
9 minutes ago, THraShArD said:

ok, this sounds like a choppy frame rate issue with full screen ?  There is some setting I remember doing with Bordered Full Screen, but should not happen with every game

Yea been thinking that too, 3 different monitors and 2 of them with gsync and still no difference. In the clip, when characters turn they stutter. Not seen in the clip but when they are close to each other they collide/overlap or shake hands 2 feet apart

Link to post
Share on other sites

thats my gpu, just before the massive spikes is in game rest is just at desktop. My other gpu did the same thing on a different setup.

Screenshot 2020-11-29 214547.png

Link to post
Share on other sites

I'd call Nvidia, you should still be under support and would love to hear what they say

CPU i7 4960x Ivy Bridge Extreme | 64GB Quad DDR-3 RAM | MBD Asus x79-Deluxe | RTX 2080 ti FE 11GB |
Thermaltake 850w PWS | ASUS ROG 27" IPS 1440p | | Win 7 pro x64 |

Link to post
Share on other sites
8 hours ago, THraShArD said:

I'd call Nvidia, you should still be under support and would love to hear what they say

Im thinking it has to be a windows 10 issue since both my rtx 2060 and my 2080 ti had the same problems?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×