Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

I forgot to put the heatsink on when troubleshooting....

So I got a new computer and it wasn't posting. I had a repair guy come and try to troubleshoot and he couldn't figure it out at all. He was using his heatsink when he came and packed it up when he left. After he left I tried a couple more things to see if I could get it to post forgetting to put my heatsink back onto it. I probably turned it on 4 times for about 20-30 seconds each and then unplugged it.

 

One of my friends mentioned that my motherboard probably needs to be updated to use the ryzen 5800x, so I contacted my motherboard support (gigabyte x570 aorus wifi pro) and they said the motherboard does need to be updated first. So that was my problem and I plan to do that tomorrow when I have some time, but now i'm worried whether or not I damaged the cpu. What do you guys think? I know there's nothing that can really be done about it now, but I just need some peace of mind before I try to get the computer put together again tomorrow.

Link to post
Share on other sites
10 minutes ago, jmido8 said:

forgetting to put my heatsink back onto

Modern CPUs have thermal shutdown code built-in, not like the old CPUs in the P2 era that you could burn out if you didn't have a heatsink on it when you powered it up. The CPU is likely just fine

So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites

Okay, thanks for the reassurance guys. I'm really hoping it'll be just fine tomorrow because if not, I probably voided the warranty and can't afford to buy a new one for another month or so lol.....

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×