Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Installing Nvidia drivers on Ubuntu also installs GUI environment?

I'm currently running ubuntu server as a VM (esxi) to host my plex application, I've added a Nvidia Quadro P2000 for transcoding and passed it through to the VM fine. My ubuntu OS currently does not have the GUI installed so it's purely CLI however when I install the Nvidia GPU drivers it also downloads and installs the minimal GUI for Ubuntu, is this unavoidable or is there a way to stop ubuntu installing the GUI environment?

 

ubuntu version is 20.04 lts

nvidia driver 450

Link to post
Share on other sites

You need to use the headless drivers.

You'll probably need to do some cleanup of your existing drivers and it would have installed X11(GUI) elements so something like


So something like below

sudo apt-get remove nvidia-* xserver-xorg* && sudo apt-get purge nvidia-* xserver-xorg* && sudo apt-get autoremove && sudo apt-get autoclean
sudo apt-get install nvidia-headless-450-server 

 

You could also install the Nvidia drivers from the run package from their site https://www.nvidia.com/en-us/drivers/unix/

When using the run file just dont run the x11-config at the end

Spoiler

Desktop: Ryzen 7 2700x | Aorus X470 Gaming Ultra | EVGA RTX2080 Super | 32GB (4x8GB) Corsair Vengeance RGB Pro 3200Mhz | Corsair H105 AIO, NZXT Sentry 3 | Corsair SP120's | 1TB Crucial P1 NVMe, 4TB WD Black | Phanteks Enthoo Pro | Corsair RM650v2 PSU | LG 32" 32GK850G Monitor | Ducky Shine 3 Keyboard, Logitech G502, MicroLab Solo 7C Speakers, Razer Goliathus Extended, X360 Controller | Windows 10 Pro | SteelSeries Siberia 350 Headphones

 

Spoiler

Server 1: Fractal Design Define R6 | Ryzen 3950x | ASRock X570 Taichi | EVGA GTX1070 FTW | 64GB (4x16GB) Corsair Vengeance LPX 3000Mhz | Corsair RM650v2 PSU | Fractal S36 Triple AIO | 10 x 8TB HGST Ultrastar He10 (WD Whitelabel) | 500GB Aorus Gen4 NVMe | 2 x 1TB Crucial P1 NVMe | LSI 9211-8i HBA

 

Server 2: Corsair 400R | IcyDock MB998SP & MB455SPF | Seasonic Focus Plus 650w PSU | 2 x Xeon X5650's | 48GB DDR3-ECC | Asus Z8NA-D6C Motherboard | AOC-SAS2LP-MV8 | LSI MegaRAID 9271-8i | RES2SV240 SAS Expander | Samsung 840Evo 120GB | 5 x 8TB Seagate Archives | 10 x 3TB WD Red

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×