Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Need help my Motherboards CPU light is on

So my PC just suddenly stopped working after i moved, the CPU light is on and i have tried changing the battery on the board, i reseated the CPU and checked all the wires. Still has the light and idk what else to do

 

CPU Ryzen 5 2600X with an EVGA AIO

 

MoBoard MSI Gaming PRO Carbon AC


GPU Gigabyte Windforce RTX 2070 Super

 

RAM Corsair Vengeance 16 gigs DDR4 3600mhz

 

PSU EVGA 850W 80+ Gold

 

Everything powers on, all the fans are spinning and all, the AIOs led flashes once really quick after powering up but then nothing, none of the rgb on the motherboard or fans light up even the power button on the case doesn’t light up like normal.

image.jpg

Link to post
Share on other sites

Remove and reinstall the RAM, hope that helps. Don't ask me why "why would RAM affected if the CPU light's on" but on a case I did troubleshoot a CPU light problem, it's actually the RAM that came loose.

Humor me, as you should do.

 

Daily drivers:

 

Acer Aspire E5-475G

Intel Core i5-7200U 2.5 GHz (Turbo 3.1 GHz) || NVIDIA GeForce 940MX 2GB

4GB Micron DDR4 + 4GB Team Group DDR4 PC19200

120 GB WD Green M.2 SATA SSD + 480 GB Pioneer APS-SL3N SATA SSD

Windows 10 Single Language x64

 

Some old computer laying around as my HTPC

Intel Pentium Dual Core E2160 1.8GHz || (fake lol) NVIDIA GeForce GT730 2GB DDR3

Some random old motherboard. Works fine tho.

512 MB + 512 MB random DDR memory

40GB IDE HDD + 1 TB old laptop SATA HDD, got bad sector unfortunately

Linux Mint 20 Ulyana Xfce x64

Some old TCL CRT TV laying around + RCA to HDMI converter

 

Xiaomi Redmi Note 8

4GB RAM, 64GB Internal Storage 

64GB SanDisk Ultra (80MB/s Read) External Storage

MIUI 11 Global

Aukey Turbo Charger PA-U28 QC2.0 + Aukey CB-CD4 PVC Type-C Cable

 

Audio

Some random home-theater speakers I took freely from someplace and big-ass bass with old computer speaker amplifier. It sounds good af tho.

dbE DJ100 Headphone

Link to post
Share on other sites
1 hour ago, dhannemon13 said:

Remove and reinstall the RAM, hope that helps. Don't ask me why "why would RAM affected if the CPU light's on" but on a case I did troubleshoot a CPU light problem, it's actually the RAM that came loose.

Done this before i think but tried againg just incase, still nothing unfortunately. Really appreciate the info though might com in handy in the future, tomorrow imma swap the CPU for a 2200G i have in an older build that i know works to check if it’s possible the Board or CPU got messed up in the move, it was a short move but the case was set on the tempered glass side pannel when my brother loaded it up so idk if the parts hanging that way damaged anything on the motherboard or if I accidentally did something when i hit the eco switch while unplugging the PSU instead of the power switch. 

Link to post
Share on other sites

So i put my old 2200G in the system and she booted right up like it was nothing, the CPU light was on for a split moment then went off and booted sorta normal

Link to post
Share on other sites
9 hours ago, Michi.Kazuma said:

So i put my old 2200G in the system and she booted right up like it was nothing

Well, either, probably unplug-replug everything that's on the motherboard would be useful either. As Linus said on this video either, because of the movement while moving the PC (especially if the inside's without any kind of 'holder') can.. Yeah, move anything inside it, might be a good idea to do so.

 

I just hope your motherboard isn't damaged, tho.

 

Spoiler

the CPU light was on for a split moment then went off and booted sorta normal

Well, it's supposed to be like that every time it boots, it's a good thing it's still running nice.

Humor me, as you should do.

 

Daily drivers:

 

Acer Aspire E5-475G

Intel Core i5-7200U 2.5 GHz (Turbo 3.1 GHz) || NVIDIA GeForce 940MX 2GB

4GB Micron DDR4 + 4GB Team Group DDR4 PC19200

120 GB WD Green M.2 SATA SSD + 480 GB Pioneer APS-SL3N SATA SSD

Windows 10 Single Language x64

 

Some old computer laying around as my HTPC

Intel Pentium Dual Core E2160 1.8GHz || (fake lol) NVIDIA GeForce GT730 2GB DDR3

Some random old motherboard. Works fine tho.

512 MB + 512 MB random DDR memory

40GB IDE HDD + 1 TB old laptop SATA HDD, got bad sector unfortunately

Linux Mint 20 Ulyana Xfce x64

Some old TCL CRT TV laying around + RCA to HDMI converter

 

Xiaomi Redmi Note 8

4GB RAM, 64GB Internal Storage 

64GB SanDisk Ultra (80MB/s Read) External Storage

MIUI 11 Global

Aukey Turbo Charger PA-U28 QC2.0 + Aukey CB-CD4 PVC Type-C Cable

 

Audio

Some random home-theater speakers I took freely from someplace and big-ass bass with old computer speaker amplifier. It sounds good af tho.

dbE DJ100 Headphone

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×