Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

? rtx3070 NOT COMPATIBLE (vga NON POST) with x570/amd (no post)

i don't know

asus x570 tuf gaming plus

amd ryzen 5 3600xt

ram 2x16gb 3600 c18 corsair vengeance lpx

psu seasonic focus 1000w 80+ gold
rtx 3070

 

case: define 7 xl

 

mobo has i think orange, red, white, green, light sequence or something during start up...

stuck on white (vga problem) light with green boot light also on... no beeps i dont think board has sound (or built in graphics)

 

basically tried everything i've read online (reseat ram, gpu, check power cords, etc - i mean, ask / please tell )

everything has fans on - the gpu fans are working, so is the cpu fan, mobo rgb, case fans, case power button

is this a problem with the cpu/mobo not recognizing the rtx 3070 as a viable display output?
is this a bios problem (fixable or ... ? )

how can i get the mobo to pass vga check during post/boot ?
do i need to update the mobo bios to work with the rtx3070?
is this a common problem *appears to be with the asus x570 tuf gaming plus mobo

i just don't understand how to help the mobo to recognize the gpu and output a display successfully 🥺

Link to post
Share on other sites

Have you tried all Motherboard slots? Have you made sure the Motherboard and CPU actually worked before hand?

 

Bios shouldnt cause the issue, but other then what youve tested, you could have a dead card. Do see if you can try it on a friends system.

Link to post
Share on other sites

i will try the next pci slot down for the graphics card, right now @Shimejii

yeah given the problems with nvidia rtx 3000 series launch, pretty sure they just packaged a total brick and sold it, tbh havent looked to see yet if the card works for anyone yet

i can try the card in my brothers computer tomorrow

is there any recourse for this sort of situation? i mean, what figures to be the best way to get a working pc out of this?

Link to post
Share on other sites

yeah even with the gpu in pci slot 2, same results... guess $170ish for the asus x570 mobo was just too good to be true

Link to post
Share on other sites
1 minute ago, TrigrH said:

are you using a riser cable?

no

Link to post
Share on other sites

no i dont have any other gpu (which perhaps might work since the mobo is old) 

and thats what i was wondering, if there was a way to update the old bios on the board, so that it could recognize new rtx 3000 series cards (but online it appears that at least most nvidia cards it won't recognize) @TrigrH

Link to post
Share on other sites

i think in the morning i'm going to start hunting local stores for a replacement mobo and start rma on the asus board

Link to post
Share on other sites
2 minutes ago, Monomoy said:

no i dont have any other gpu (which perhaps might work since the mobo is old) 

and thats what i was wondering, if there was a way to update the old bios on the board, so that it could recognize new rtx 3000 series cards (but online it appears that at least most nvidia cards it won't recognize) @TrigrH

Not without being able to post first. You sure you don't have anything even if its old? Has this system been working in the past or?

1 minute ago, Monomoy said:

i think in the morning i'm going to start hunting local stores for a replacement mobo and start rma on the asus board

Its unlikely the board is faulty. 

Link to post
Share on other sites

currently i have a laptop, and no spare cards - unless i can use my brothers 1660ti tomorrow, 

hmm are you suggesting that by using a compatible card to post, it could be patched to work with the 3070? @TrigrH

 

i gathered these parts the past month, built the computer this evening, never having built a computer before

Link to post
Share on other sites
35 minutes ago, Monomoy said:

currently i have a laptop, and no spare cards - unless i can use my brothers 1660ti tomorrow, 

Try that first, at the very least it can help isolate the issue.

Quote

hmm are you suggesting that by using a compatible card to post, it could be patched to work with the 3070? @TrigrH

Maybe, without testing a known good card its hard to say what is at fault here.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×