Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Watch dogs Legion - low FPS

So in Watch Dogs Legion, it performed well during the first part of the game. When I went onto the streets, my FPS would hover around 40-45 FPS no matter how low I turned the settings. The weird thing is my CPU usage is completely normal but my GPU is pegged at around 65% usage. I don't seem to have this issue in any other games, although Far Cry 5 dips a bit but never below 60. Some of my other games such as Assassins' Creed Origin and Ghost Recon Breakpoint bottleneck my CPU but the CPU usage is actually extremely high.

 

My specs are as follows: i7 4790 3.6 MHZ, 2080 ti, 16 gb ddr3 1600 MHZ.

 

Screenshot of Watch Dogs Legion:

 

Edit, already updated graphics card drivers, restarted my pc, verified the integrity of the game, and just downloaded the latest update.

Edit 2, benchmark also works just fine

 

 

Screenshot_(31).png

Link to post
Share on other sites

Set up MSI Afterburner's OSD to show usage for each individual core, make sure it isn't pegged to 100% on a single core and thus choking. 

X58-X79-X99-X299 lads: Intel HEDT Xeon/i7 Megathread 

 

Current Main - i7 6950X (currently stock) - EVGA CLC 280 - EVGA X99 Micro 2 - 32 GB RAM [4x8GB HyperX Predator DDR4] @3200Mhz CL16-18-18-36 CR2 - Nvidia FE 2060 Super - 1TB 970 Evo - Corsair RM1000i - Fractal Design Meshify C Mini - 4x Noctua iPPC NF-A14 3000s + 1 Noctua iPPC NF-F12 2000
 

Bits - i7 5960X - undecided - EVGA X99 Classified - 16 GB RAM [4x4GB EVGA SSC DDR4] - undecided - 250GB 960 Evo - undecided - Corsair 750D

 

Mac Pro 1,1 - (EFI flashed to 2,1) - 2x 2.66Ghz Dual Core LGA771 Xeons (2x X5355s - just need the motivation/time to actually install them) - 32GB 667Mhz ECC DDR2 - ATI HD4870 512MB - 525GB MX300 + 3x 2TB Seagate Barracuda HDDs - 24" Apple Cinema Display (1920x1200 TFT panel)

 

2019 13" rMBP (i5/8GB/256GB) {work} - 2012 13" MBP (i5/16GB/1TB MX500 + 2TB Firecuda) {mine} - iPhone 11 Pro Max + Apple Watch S3 42mm - iPod Classic 6G 80GB running Rockbox + iPod Classic 5.5G Enhanced 30GB also on Rockbox 

Link to post
Share on other sites
4 minutes ago, Zando Bob said:

Set up MSI Afterburner's OSD to show usage for each individual core, make sure it isn't pegged to 100% on a single core and thus choking. 

I did, is my screenshot showing up? My highest core is 77%.

Link to post
Share on other sites

I read onto something if Watch Dogs Legion's still not a good game yet to get decent fps somewhere around the forum...

Humor me, as you should do.

 

Daily drivers:

 

Acer Aspire E5-475G

Intel Core i5-7200U 2.5 GHz (Turbo 3.1 GHz) || NVIDIA GeForce 940MX 2GB

4GB Micron DDR4 + 4GB Team Group DDR4 PC19200

120 GB WD Green M.2 SATA SSD + 480 GB Pioneer APS-SL3N SATA SSD

Windows 10 Single Language x64

 

Some old computer laying around as my HTPC

Intel Pentium Dual Core E2160 1.8GHz || (fake lol) NVIDIA GeForce GT730 2GB DDR3

Some random old motherboard. Works fine tho.

512 MB + 512 MB random DDR memory

40GB IDE HDD + 1 TB old laptop SATA HDD, got bad sector unfortunately

Linux Mint 20 Ulyana Xfce x64

Some old TCL CRT TV laying around + RCA to HDMI converter

 

Xiaomi Redmi Note 8

4GB RAM, 64GB Internal Storage 

64GB SanDisk Ultra (80MB/s Read) External Storage

MIUI 11 Global

Aukey Turbo Charger PA-U28 QC2.0 + Aukey CB-CD4 PVC Type-C Cable

 

Audio

Some random home-theater speakers I took freely from someplace and big-ass bass with old computer speaker amplifier. It sounds good af tho.

dbE DJ100 Headphone

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×