Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Second Monitor Flickering

Go to solution Solved by tishous,

Nvidia drivers can be a bit funny when it comes to multi-monitor setups. Try uninstalling the drivers and installing an earlier driver and see if the problem continues.

Hello!

 

Recently my left monitor has started flickering at the top of the screen. It seems inconsistent, as in, I don't do anything in particular and it flickers and sometimes it doesn't flicker for a long period of time.

I don't think its a monitor issue because I did some testing. I used each of the monitors separately for a while and no flickering whatsoever.

Both my monitors are: LG 24GL65B-B https://www.newegg.ca/p/N82E16824025966?Item=N82E16824025966

My GPU: EVGA GeForce RTX 2070 super

 

Things I have done;

  • Reinstalled my drivers
  • Changed the monitor cords
  • Changed the ports that the monitors plug into on my GPU

They weren't flickering previously so I am wondering if it will go away on the next driver update.

 

If you have any suggestions that could fix this problem let me know!

 

Thanks!

Link to post
Share on other sites

Nvidia drivers can be a bit funny when it comes to multi-monitor setups. Try uninstalling the drivers and installing an earlier driver and see if the problem continues.

Link to post
Share on other sites
2 minutes ago, tishous said:

Nvidia drivers can be a bit funny when it comes to multi-monitor setups. Try uninstalling the drivers and installing an earlier driver and see if the problem continues.

I'll give that a try thanks!

Link to post
Share on other sites

When i first load windows i get flickering on my main monitor but its only since a driver update from Nvidia.  It flickers about 5-6 times and then all is well.

MAIN PC (Beast) - Asus ROG Crosshair Hero VII WIFI , AMD Ryzen 7 2700x + Corsair H115i Pro RGB Cooling, 32GB G.Skill 3200Mhz 16,18,18,38 1.35v DDR4, Inno3d HerculeZ Design Nvidia GTX 1080 X2 8GB GDDR5,  2 x Samsung U28E590D 3840 x 2160 4K, 1 x Samsung Evo 970 Evo Plus NVME PCI-E 1TB, 1 x Samsung Evo 850 250GB, 1 X Sandisk Ultra II SSD 240GB + 2 X 3TB Seagate Baracuda SATA III, 1 x LG BH16NS40 16x BR\DVDRW, ICYBOX IB3740-C31 & ICYBOX IB3640-03, Corsair Obsidian 750D Windforce Edition Case + 5 Corsair ML140 140mm Case Fans, EVGA 750 g3 750w Gold 80+ PSU, Logitech MX Vertical Mouse, Corsair K55 RGB Gaming Keyboard, Windows 10 Pro x64 Retail, Synology ds215j NAS + 2x3TB WD Reds connected to a 6TB Seagate USB 3.0 Backup Plus Hub, Blue Yeti Microphone, Logitech C922 Pro HD,  Logitech C920 Pro HD, Kaspersky Internet Security 2020.

 

Second PC (Cyclops) - MSI 990FXA Gaming, AMD FX 8370 4Ghz, Corsair 16GB Venegence Red 9-9-9-24 1600Mhz, Arctic Cooling Freezer 13, Asus Strix 1050TI 4GB, 1 X Acer 27" Full HD Monitor, 1 X Sandisk Ultra II SSD 240GB, 1 x Samsung Evo 850 250GB, 2 X Seagate Baracuda 2TB, 1 X WD Black 2TB, 1 x ASUS 16x DVDRW, X-Case Eagle III Case, 3 X Corsair AF 120 Case Fans, EVGA 850 G2 80+ Gold + PSU, Logitech MX Master Mouse, Corsair K30 Keyboard, Logitech C920 Webcam, R0DE NT1-A Microphone, Scarlet 212 Audio Interface (Revision 2), Windows 10 Pro X64 Retail, Kaspersky Internet Security 2020, 2TB Seagate Expansion USB Hard Drive.

 

Third PC (Old Trustie) - Acer Aspire M3400, OEM Mainboard, AMD FX Athlon II X3 425 2.7Ghz, 16GB Corsair Value 1600Mhz Ram, OEM CPU Cooler, AMD R7 260 2GB GPU, 1 X Acer 27" Full HD Monitor, 1 X Sandisk Ultra II SSD 240GB, 2TB Samsung SATA III, 1 X OEM 16X DVDRW, 1 X Acer OEM Case, 1 X Corsair AF120 Case Can, Corsair CX500 Bronze+ CPU, Logitech MX Master Mouse, Corsair K30 Keyboard, Windows 10 Home X64 OEM, Logitech C920 Webcam, Kaspersky Internet Security 2020.

 

Icybox 3640SU3

Icybox 3740-C31

Printers Include - Canon MG5750, Canon, IP8750, 2 X Samsung C410W.

 

Netgear Nighthawk R6 R8000 Cable Router with DD-WRT Using a Virgin Media Hub 3.0.

 

Samsung Galaxy S10 Mobile Phone.

 

Internet Speed.....

https://www.speedtest.net/result/9935039193

Link to post
Share on other sites
20 minutes ago, tishous said:

Nvidia drivers can be a bit funny when it comes to multi-monitor setups. Try uninstalling the drivers and installing an earlier driver and see if the problem continues.

I reverted back to a September driver and so far no flickering. It seems like it is a driver related issue, so I guess just have to wait for the next driver to come out.

 

Thanks for the suggestions!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×