Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Low FPS with RTX 3080 on LOL

Game: League of Legends

 

I have a Ryzen 7 3700X 4.3 GHz paired with a RTX 3080 FE, with all updated drivers. I am only receiving about 100-160 fps on League of Legends, 1440p Maxed Settings. LOL is not a game that requires that much to run, there is definitely something wrong. I received the same amount of frames back when I used a Ryzen 5 2600 paired with a RX 580 4GB. Every other game that I play has perfect frames for it, but league is different. I ran 3D Benchmark and received a score of 15,183 too. I have VSYNC off, GSYNC off, and any frame limiter off. If there's any other League players out there that uses a 3080 what's your FPS in the game. What could be wrong?

 

Benchmark Link: https://www.3dmark.com/3dm/52204190?

 

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites

Is league the only game that suffers insufficient performance?

 

Edit

my question was answered in your post. I would suggest a reinstall.

I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Kill Trident Z RGB - Force MP500 - Jedi Order Titan Xp - Hyper 212 Black (with RGB Riing flair) - EVGA G2 650W - Black and green theme, Razer branwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Dual Xeon X5560 - 24GB ECC DDR3 - GTX 750 TI - old Seagate 1.5TB HDD - Dark moded Ubuntu (and Win7, cuz why not)

 

How many watts do I need? Seasonic Focus threadUserbenchmark (Et al.) is trash explained, PSU misconceptions, protections explainedgroup reg is bad

Link to post
Share on other sites
1 minute ago, Fasauceome said:

Is league the only game that suffers insufficient performance?

 

Edit

my question was answered in your post. I would suggest a reinstall.

I have reinstalled the game, twice. It's always the same. In a benchmark video, the creator had about 250-300 fps on maxed 1440p. Why is mine different I wonder

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites
2 minutes ago, Fasauceome said:

Is league the only game that suffers insufficient performance?

 

Edit

my question was answered in your post. I would suggest a reinstall.

This is unexpected low performance for the CPU and GPU that I have

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites
6 minutes ago, DHV0 said:

This is unexpected low performance for the CPU and GPU that I have

Have you tried adjusting your Nvidia control panel settings? specifically the power management mode?

Link to post
Share on other sites
1 minute ago, Sorenson said:

Have you tried adjusting your Nvidia control panel settings? specifically the power management mode?

 

1.PNG

2.PNG

3.PNG

4.PNG

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites

@DHV0 I would try restoring the nvidia app to default and choosing "Ryzen Balanced." 

Link to post
Share on other sites
1 minute ago, Sorenson said:

@DHV0 I would try restoring the nvidia app to default and choosing "Ryzen Balanced." 

Restored and tested it currently I still have the 120-160 FPS

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites
3 minutes ago, DHV0 said:

Restored and tested it currently I still have the 120-160 FPS

Maybe use MSI afterburner to see if you have a bottleneck anywhere. It might just be a bug with the drivers then since it's a new architecture. You should definitely be getting more. I got more FPS with a 3800x and a 2070 super on a 3440x1440 monitor.  

Link to post
Share on other sites
2 minutes ago, Sorenson said:

Maybe use MSI afterburner to see if you have a bottleneck anywhere. It might just be a bug with the drivers then since it's a new architecture. You should definitely be getting more. I got more FPS with a 3800x and a 2070 super on a 3440x1440 monitor.  

I don’t think it’s bottlenecking since the usage is below 30 for CPU and GPU

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites
4 hours ago, DHV0 said:

I don’t think it’s bottlenecking since the usage is below 30 for CPU and GPU

I would suggest resetting the nvidia cp completely, maybe even reinstall the drivers and don't change anything *except* in global settings power profile to "adaptive" 

 

And try windows power plan "balanced" 

 

Change anything you want to change like vsync etc *in game* and not in nvidia cp. 

 

 

 

RYZEN 5 3600 | EVGA GTX 1070 FTW2 | 16GB CORSAIR VENGEANCE LPX 3200 DDR4 | MSI B350M MORTAR | 250GB SAMSUNG EVO 860 | 4TB TOSHIBA X 300 | 1TB TOSHIBA SSHD | 120GB KINGSTON SSD | WINDOWS 10 PRO | INWIN 301| BEQUIET PURE POWER 10 500W 80+ SILVER | ASUS 279H | LOGITECH Z906 | DELL KB216T | LOGITECH M185 | SONY DUALSHOCK 4

 

LENOVO IDEAPAD 510 | i5 7200U | 8GB DDR4 | NVIDIA GEFORCE 940MX | 1TB WD | WINDOWS 10 GO HOME 

Link to post
Share on other sites
2 hours ago, Mark Kaine said:

I would suggest resetting the nvidia cp completely, maybe even reinstall the drivers and don't change anything *except* in global settings power profile to "adaptive" 

 

And try windows power plan "balanced" 

 

Change anything you want to change like vsync etc *in game* and not in nvidia cp. 

 

 

 

I have reinstalled drivers, the game, turned off anything like vsync, and turned on powere plan balanced; still the same :( I think its just league tbh everything is fine 

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites
5 hours ago, Zindokar said:

I play 1080p but I get my 165fps in LoL vsync on, I have 165hz monitor... I have a gigabyte 3080rtx. My score is like than your time spy benchmark https://www.3dmark.com/3dm/51904195 

Im playing on 1440p, I think it's just that league is not fully optimized for 3000 series

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites
20 hours ago, DHV0 said:

 

1.PNG

2.PNG

3.PNG

4.PNG

turn the power management to prefer maximum performance instead of optimal power see if that helps

Link to post
Share on other sites
9 hours ago, rijzen said:

turn the power management to prefer maximum performance instead of optimal power see if that helps

I tried it already, I asked riot support to see if they could help; they suggested turning off services that do not include microsoft windows in msconfig. I had 600 fps in the spawn/nexus then it dipped fast down to 120. They said it's probably just optimization due to the card being so new

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites

I am having the exact same issue but then with an RTX 3090. Also started a thread on reddit but not much response. 

https://www.reddit.com/r/nvidia/comments/j9zkp4/low_fps_with_3090_while_playing_league_of_legends/

 

Like you I am also thinking this has something to do with the drivers. Our specs are totally different, we both have a 3000 series GPU and that is about it. 

 

My specs: 

Intel Core i7-7820X Processor @ 4.539 MHz

 

NVIDIA GeForce RTX 3090

ASUSTeK COMPUTER INC. ROG RAMPAGE VI EXTREME

32,768 DDR4 @ 3200Mhz

 

Everything is running perfectly (score 3dmark:17 121) except for league. I am playing in 4K and the FPS goes below 100 sometimes.

I used to have a 1080Ti in this system and was having better FPS in league. The only thing changed is the 3090.

 

 

Link to post
Share on other sites
4 hours ago, Mokle said:

I am having the exact same issue but then with an RTX 3090. Also started a thread on reddit but not much response. 

https://www.reddit.com/r/nvidia/comments/j9zkp4/low_fps_with_3090_while_playing_league_of_legends/

 

Like you I am also thinking this has something to do with the drivers. Our specs are totally different, we both have a 3000 series GPU and that is about it. 

 

My specs: 

Intel Core i7-7820X Processor @ 4.539 MHz

 

NVIDIA GeForce RTX 3090

ASUSTeK COMPUTER INC. ROG RAMPAGE VI EXTREME

32,768 DDR4 @ 3200Mhz

 

Everything is running perfectly (score 3dmark:17 121) except for league. I am playing in 4K and the FPS goes below 100 sometimes.

I used to have a 1080Ti in this system and was having better FPS in league. The only thing changed is the 3090.

 

 

but with 3090 rtx every proccessor on the market is a bottleneck, ryzen 3900X versus i9-10900k, intel get in some games at 4k 40 fps more than ryzen.

Link to post
Share on other sites

whats task manager looking at for gpu and cpu per core.

.Waiting for intel 7nm, navi 23, zen 11...

.

.

Updated: Too long ago

Alienware 17r5

3700x/1080

500D SE/3600/1060 STRIX VERTICAL/AG352UCG6 120hz 1440p gsync ultrawide / TOO MUCH RGB

A few negligible workstation builds

Gaming Routers are Stupid

I have a RGB Problem

/pcmasterrace /widescreenmasterrace

 

Audiophile, EL8 Titanium go to drivers for weight to performance ratio.

Music Setup Cubase 10 PRO, Adam A8X, Adam Sub8.

 

I dont ask stupid questions, I just word them stupid so you think its stupid.

im not stupid your stupid calling me stupid stupid

Why are you still reading this this is prob all wildly outdated as i just found out how to change signature and ill prob never be bothered again hahahahhahahahaa.

 

The word "Gaming" and anything around it is cringe. E.G

 

I'm a gamer les go play fortnite. In cringe 9 year old voice.

I want a Gaming Computer to play fortnite. In cringe 9 year old voice.

 

Gaming is dumb enthusiast is cool.

 

Whitebread > Brownbread

Coffee>Tea

PoachedEgg>FriedEgg

Idk how many lines this is im not counting im prob breaking rules #rebel

Link to post
Share on other sites

@The Torrent @Zindokar

 

I did some more research using MSI afterburner to log a custom LoL game session. 

 

The GPU is basically doing nothing:

GPUsleep.thumb.PNG.46a11acc33eaeeabf56359a82f5a8b28.PNG

 

There is one CPU core that is doing much work but its not going to 100%  (core16):

cpu1.thumb.PNG.9d22ff84ca7acf601691bd73248f90ab.PNG

cpu2.thumb.PNG.43500033763121596498d2969f170af3.PNG

 

I think the issue here is either the driver or the way LoL handles multi threading. Other applications are able to fully utilise the 3090.

 

This is taken just after running 3d mark. It pushes the power limit of the 3090 up to 117%.

image.png.3b924bfa8e9f61c7a46081f96da3b23e.png

Also when looking at the CPU core usage you can see even distribution. Also the cores only go to 100% during the CPU test. This means that the GPU is still the bottleneck when running the graphics benchmarks:

image.png.9aa4aa29a5debd082677cf00a2e3fb71.png

 

Link to post
Share on other sites
9 hours ago, Mokle said:

I am having the exact same issue but then with an RTX 3090. Also started a thread on reddit but not much response. 

https://www.reddit.com/r/nvidia/comments/j9zkp4/low_fps_with_3090_while_playing_league_of_legends/

 

Like you I am also thinking this has something to do with the drivers. Our specs are totally different, we both have a 3000 series GPU and that is about it. 

 

My specs: 

Intel Core i7-7820X Processor @ 4.539 MHz

 

NVIDIA GeForce RTX 3090

ASUSTeK COMPUTER INC. ROG RAMPAGE VI EXTREME

32,768 DDR4 @ 3200Mhz

 

Everything is running perfectly (score 3dmark:17 121) except for league. I am playing in 4K and the FPS goes below 100 sometimes.

I used to have a 1080Ti in this system and was having better FPS in league. The only thing changed is the 3090.

 

 

Tyler1 is also having low performance on league with a 3080

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites
  • 3 weeks later...
On 10/27/2020 at 10:54 PM, DHV0 said:

Game: League of Legends

 

I have a Ryzen 7 3700X 4.3 GHz paired with a RTX 3080 FE, with all updated drivers. I am only receiving about 100-160 fps on League of Legends, 1440p Maxed Settings. LOL is not a game that requires that much to run, there is definitely something wrong. I received the same amount of frames back when I used a Ryzen 5 2600 paired with a RX 580 4GB. Every other game that I play has perfect frames for it, but league is different. I ran 3D Benchmark and received a score of 15,183 too. I have VSYNC off, GSYNC off, and any frame limiter off. If there's any other League players out there that uses a 3080 what's your FPS in the game. What could be wrong?

 

Benchmark Link: https://www.3dmark.com/3dm/52204190?

 

Hi.

 

I have exactly same issue - did you find any fix for that?

 

From what I can tell - updated vBIOS of the GPU - no result.

Drivers re-installation - not any improvement neither.

 

I have also disabled Windows game mode, tried game re-installation and many many others. The performance in other games is as expected, but with LoL it is just pathetic.

 

BR

LegoBatmanRules

Link to post
Share on other sites
1 hour ago, LegoBatmanRules said:

Hi.

 

I have exactly same issue - did you find any fix for that?

 

From what I can tell - updated vBIOS of the GPU - no result.

Drivers re-installation - not any improvement neither.

 

I have also disabled Windows game mode, tried game re-installation and many many others. The performance in other games is as expected, but with LoL it is just pathetic.

 

BR

LegoBatmanRules

I upgraded to the 5600X and it seems to be fixed I suppose. I have a constant 600-700 FPS in League of Legends.

CASE: NZXT H510 ELITE MOTHERBOARD: ASUS ROG Strix B550-F Gaming (WIFI 6) CPU: AMD Ryzen 5 5600X 4.7GHz (ZEN 3COOLING: Arctic Freezer II AIO 280mm RAM: 32GB Corsair Vengeance RGB PRO 3200MHz CL15 GPU: NVIDIA RTX 3080 Founder's Edition PSU: Thermaltake RGB 850w 80+ Gold STORAGE: SSD Samsung 860 EVO 250GB // M.2 NVME WD BLACK 1TB // M.2 NVME Samsung 970 EVO 1TB // HDD Seagate 2TB OS: Windows 10 Home x64 Bit MONITORS: LG 27GN850-B @144Hz 1440p // Acer XF270H @144Hz 1080p MOUSE: Razer Viper Ultimate Mercury White KEYBOARD: Razer Huntsman TKL (w/ Razer Mercury White Keycaps) HEADSET: HyperX Cloud Flight

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×