Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Strange issue: Inconsistent RTX 2070 Super Performance

I recently bought an RTX 2070 Super to eventually step-up to a 3080 from EVGA. I've noticed some issues while using the card, and I've been having trouble identifying their source:

I play on both my 1440p monitor and my 4K tv. I usually play at 1440p resolution on both, but for some games, I've checked online to see if they can handle 4k. 3 games I've been playing over the last week are Gears of War 4, Resident Evil 7, and Wolftenstein: Youngblood. In each of them, I will start off with great 4k performance (staying at 60fps) and then at random points in each game, my FPS will tank to the 20s or 30s. In each game, I continue having issues even after switching to 1440p resolution. I usually have to exit out of the game and reload to fix the issue, but sometimes even then it persists. I'd normally just think my GPU can't run the games at 4K, but I've seen other people's results with similar hardware and I know it should be able to.

For example, Wolftenstien: Youngblood can run at 4k60 using DLSS and RTX at the highest settings on a 2070 Super. When I run the in-game benchmark, I will get 60+fps maybe 2 out of ten times. The other 8 it will average about 18.

I don't think it's the GPU itself - the GPU stays cool, never exceeding 66 C, and the fans are on a custom curve I've set. The drivers are updated. I've updated my BIOS and attempted to update my chipset drivers, although the installer says I don't have an AMD system and then it aborts, which is strange. I read somewhere that it may be an issue with my windows registry, although I'm not sure how to change that. This is the same version of windows I was using with an old i7-4790k until earlier this year, although I didn't have issues with my GTX 970.

Another issue may be that I have some sort of malware on my PC. Windows Defender and Malwarebytes don't report anything in their scans, but while running the Wolfenstein benchmark last night, my PC randomly started running Microsoft Flight Simulator 2020 at the same time, and the background image for my desktop changed (I'm not synced with other PC's and I don't have the background settings set to slideshow).

Is this an issue with my chipset or with an infection? Should I just do a clean install of windows? If this isn't the appropriate spot for these questions, I can also try them in a different part of the forums.

My PC specs:
CPU: Ryzen 5 3600
MOBO: AsRock X570M Pro 4
RAM: 16 GB Kingston HyperX 3200mhz
GPU: EVGA RTX 2070 Super XC Ultra
Drives: Samsung 840 EVO, Crucial M.2 1TB, OCZ Vertez 3 256 GB, Western Digital 2tb HDD

 

 

Link to post
Share on other sites

you could try DDU-ing the driver and reinstalling them

Things I need help with:

Spoiler

none atm

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Spoiler

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer: shit tier quality products, shit tier customer service thus far, they "tried" to solve my issue but they arent really doing anything but delaying and delaying. (on-going case since July)

Gigabyte: horrible customer service (gigabyte had literally 0 customer service, asked me to go to retailer with NO WAY to email them about a question) but at least they fixed my shit in ONE MONTH (would probably take me 1 hour to fix if they let me email them)

XiaoMi Phones: built like a tank but the software is buggy as all hell

Seagate HDD: had too many dead seagate drives

Kingston SSD: 300V controller swap thingy

Razer (except their mouse)

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

 

 

Link to post
Share on other sites

So I have an Asus ROG Strix 2070 Super and when playing COD MW I noticed that while running at 1440p 165hz in certain maps I would go from a solid 120 fps down to as low as 15 to 20. After doing some searching it turned out to be ray tracing that was the culprit. Turned it off and gained 10fps solid. Have you tried turning ray tracing off ?

 

Link to post
Share on other sites

Oddly enough, I'm seeing a similar randomly weird performance bug in one particular game I tested as well.  I would recommend a DDU & driver reinstall as well like others have suggested, I'm probably going to do that myself & see what happens.

What's odd is in my case it's an older game (Mafia 2), and it happened on both the 2070 Super I had & now the 3080 as well, so I'm thinking it's probably a driver issue.

 

Oh, and good luck on the Step Up queue, I'm in it as well with my 2070 Super... if they actually allow me to get another 3080, I'm gonna see if I can step up my current 3080 to a 3090 & then resell the step up 3080... wow that hurts my brain just typing it.

Primary Rig:

CPU: Intel i9-9900K @ 5GHz 1.31V ~  Mobo: Gigabyte Z390 AORUS Master

CPU Cooler: Thermaltake Floe RGB 280mm AIO (Push/Pull with Thermaltake Riing & Pure fans)

RAM: 4x8GB G.Skill TridentZ RGB 3600MHz CL16 (F4-3600C16Q-32GTZR) @ 4000MHz CL17 1.42V

GPU: eVGA RTX 3080 FTW3 Ultra @ Stock (for now)

PSU: eVGA SuperNova P2 1200W - Case: Thermaltake View 91

SSDs/HDDs: Samsung EVO 860 500GB, Samsung EVO 860 1TB, Samsung QVO 1TB, Seagate FireCuda 2TB (Hybird HDD)

Windows 10 of course - which I don't mind, so far

Link to post
Share on other sites
5 hours ago, MedicGarou said:

So I have an Asus ROG Strix 2070 Super and when playing COD MW I noticed that while running at 1440p 165hz in certain maps I would go from a solid 120 fps down to as low as 15 to 20. After doing some searching it turned out to be ray tracing that was the culprit. Turned it off and gained 10fps solid. Have you tried turning ray tracing off ?

 

So, normally that's what I'd figure - that there was one specific setting tanking everything. However, for the one game with ray tracing, both NVIDIA and Digital Foundry show my card running the game at more than 60fps with ray tracing turned on. I also saw other people in forums and on youtube getting those numbers, so I knew that meant that there was something else afoot. 

 

9 hours ago, Moonzy said:

you could try DDU-ing the driver and reinstalling them

 

Thank you for recommending this! I don't know why I didn't think of it earlier. I DDU'd the drivers after work and it seems to have done the trick - ran the Wolftenstein benchmark a few times and had it at more than 70fps at max settings + ray tracing with DLSS balanced 4K. Just played an hour of RE7 at 4k without any issue either. Gonna give it another day or two of playing to make sure the problems don't come back again like they did last week. 

 

1 hour ago, HoneyBadger84 said:

Oddly enough, I'm seeing a similar randomly weird performance bug in one particular game I tested as well.  I would recommend a DDU & driver reinstall as well like others have suggested, I'm probably going to do that myself & see what happens.

What's odd is in my case it's an older game (Mafia 2), and it happened on both the 2070 Super I had & now the 3080 as well, so I'm thinking it's probably a driver issue.

 

Oh, and good luck on the Step Up queue, I'm in it as well with my 2070 Super... if they actually allow me to get another 3080, I'm gonna see if I can step up my current 3080 to a 3090 & then resell the step up 3080... wow that hurts my brain just typing it.

Thanks, good luck to you too! I bought my 2070 Super after a bit over a week of auto refreshing store pages. It just wasn't worth all the extra effort - this is more than twice as powerful as my 970, and should let me play Cyberpunk at 1440p with high settings, DLSS, and some ray tracing features. That's if I don't get the 3080 by then. Might try for the 3070 too, if I can snag one beforehand. 

 

 

Link to post
Share on other sites

Yeah, last night the frames dropped again, although not as bad. I was getting about 30fps in Wolftenstein after spending some time in the menus upgrading weapons. 

 

The only other things I can think to try are DDUing again and updating the chipset drivers. To do the latter I think I'd need to do a clean install, which I won't fully have time for a couple days because of work, but it has been helpful knowing that other people have noticed a similar issue. 

 

 

Link to post
Share on other sites

Actually, I was just poking around during a break and saw in my NVIDIA control settings that the DSR setting is set to 2.0. From what I understand, this increases the number of pixels on the screen past the native resolution. Could this be something else causing the problem? 

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×