Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Problems installing Windows 10 to NVME Drives

Hello all,

 

I'm having some issues installing Windows 10 onto an NVME drive in my new build. I've never worked with NVME before so hopefully it's something simple.

 

For the first stage of my build I used a Z490 asus Tuf gaming plus WIFI. Soon realised it wasn't going to deliver the overclokcing I wanted so I swapped it out for a Maximus VII Hero. At this point I'd been able to set up the NVME drive on the TUF board as my windows drive without a problem.

 

I move everything over to the Maximus VII Hero.
(other bits: 10850K, 16gb RAM, RTX 2080 super waterforce, 1000 watt PSU (long story), NVME is an adata XPG 1TB)

 

The windows boot from the NVME doesn't work. No problem, swapping motherboards can cause that so I try to format the drive and reinstall windows from a USB drive, created from the download tool that day (anything of any importance has been long since backed up). After restarts and extensive goolging I've still not solved the issue, which manifests thusly:

 

BIOS seems to recognise the card fine. BIOS tests on the card pass.

Booting from the install drive the windows installer can see the NVME drive, but always shows it as 2048 GB (It was a a 1 TB drive).

Plethora of error messages as to why windows can't install on the drive (and seemingly can't format it, delete it, new partition- all greyed out):

     Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks.

     Windows cannot be installed to this hard disk space. Windows must be installed to a partition formatted as NTFS.

     Windows cannot be installed to this hard disk space. The partition is of an unrecognised type.

 

Gooling around leads to the idea I need to convert the disk to GPT. Diskpart, clean, convert gpt, refresh the list in the windows installer aaaaand... no different.

Other suggestions are that the disk should be GPT anyway.

 

I even tried using rufus to make a boot image specificall for GPT. No joy.

 

I bought a second, 2TB NVME drive (sabrent rocket Q 2TB), exactly the same problems.

More googling leads to suggestions that CSM should be enabled and secure boot disabled. No joy, just a lower res BIOS and installer, with the added bonus one of the rufus partitions (presumably the one I Set for UEFI and GPT) won't work either. It may be I just didn't have the right combination of secure boot, CSM and secure boot key deletion (whatever that is), but given all that seems to be focused on getting a non UEFI install I'm not sure how it's supposed to help anyway.

The mother board offers one 'helpful' 'error':
     Due to Microsfot Secure Boot regulations, ensure the Microsoft signed UEFI driver is contained ion the plugged in PCI-E based sotrages including M.2 SSD before set the launch CSM to [Disabled]. Otherwise, the PCI-E based storages will only be available for data drive usage. Contact the PCI-E storage venfor for the UEFI driver availability details.

 

Well that's... helpful? For an encore should I open the crate with the crowbar inside it? I can't be parsing that right, but it's probably the closest to an indicator of success.

Mooching around Asus, Adata and Sabrent I couldn't find any driver downloads, at least nothing that wasn't meant to be installed in a windows envreionment already up and running- and those were just the regular MOBO drivers/bloat.

 

Some guides seem to infer that you start the BIOS in non UEFI mode, then after the windows installer restarts the first time you go back to UEFI in BIOS. This seems to make more sense but contradicts the 'NVME can't do MBR' idea I've (possibly mistakenly) picked up. Plus I haven't been able to get it to work but if anyone's sure that's the solution I'm willing to accept PEBCAK error and try again.

I write this post on the same hardware, but with a windows install running off one of the SSDs I was looking to replace. So the rest of the hardware is working okay (I think).

 

Then I drank heavily, then I came here, then it was now and then I don't know what happened.

Can anyone offer any help? Or a cricket bat?

P.S
Sorry for the apalling spelling. I rely on a spell cehcker and can't be arsed getting it set up on a firefox install on a hard drive I'm actively trying to get rid of. :P

Link to post
Share on other sites

Here's how the drive (Disk 1) looks at the momen in windows disk manager of it helps. This is the Sabrent 2TB, but the same problems occur with the 1TB adata.

diskmanager.png

Link to post
Share on other sites

Solved it. Sort of. Solution requires you to have a windows install on another disk, but this worked for me:

 

1. Make sure your motherboard is set up for UEFI mode with compatability options disabled. You want it running in full EFI right off the bat.

 

2. Boot into windows (on your other disk drive) and open the disk manager. Also open a command prompt window.

 

3. Check you can see your disk in disk manager. Open DISKPART in the command prompt, select the disk you are trying to get windows installed on.

 

4. Run clean. The disk should show up in the diskmanager as not initialtised. Close the command window, you don't need it anymore.

 

5. From disk manager, initialise the drive.

 

6. Format the drive.

 

7. Reboot from your install medium. You should now be able to install windows to the NVME drive.

 

How you're supposed to do a clean install of windows to an NVME Drive without a spare drive I do not know...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×