Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC used to be so smooth on games like fortnite but now its slimy and latent

When I first made my PC a year ago I had no issues and everything ran perfectly, I think it was windows 1809. But now after I updated and am now at the latest version of windows fortnite is randomly slimy and acts as if vsync is on. Most of the time after restarting my computer its normal but sometimes I even have to reinstall windows to get it smooth. Razer synapse sometimes doesn't recognize any of my peripherals and geforce experience does not have the sharing and in game overlay options. 

 

Is this something to do with the new windows, bad compatibility of my parts with the new windows or possibly a bad program I installed

 

Let me know if there is any other easy to install operating systems or easy ways to get windows 7 or an older windows 10

Link to post
Share on other sites

Specs? 

I am still TechWizardThatNeedsHelp, just less of a mouthfull.

 

My beautiful, but not that powerful, main PC:

My new PC I'm saving for:                                                                /\

(was a H1 build, but I cant spend 400$ on a case)                |

DREAM BUILD BIT BY BIT                        |

  • Ryzen 5 5600x                                                                         |
  • ROG Strix B550-f GAMING                                                 |
  • 2x8gb Corsair Vengance LPX DDR4 3200mhz cl6   |
  • Old drives from Grandma -------------------------------------/
  • New Crucial P1 and Seagate Barracuda Compute 2TB
  • Whichever 3070 I can get
  • Meshify C with tempered glass
  • 6 Cooler Master MasterFan MF120 Halo
  • Full custom loop water cooling.

https://pcpartpicker.com/user/HelpfulTechWizard/saved/s8XrD3

Link to post
Share on other sites

Specs? Temps? Well fortnite has updated alot since that time, 

Reminder⚠️

I'm just speaking from experience so what I say may not work 100%

Please try searching up the answer before you post here but I am always glad to help

Link to post
Share on other sites

When I restart my computer 60% of the time it goes back to its normal responsiveness and smoothness so Im not sure if its the game.

Ryzen 5 3600
Aorus B450 Pro WiFi
GSkill Trident Z 16 GB 3600 MHZ
RTX 2060 Super (3x Gigabyte)
Deepcool Matrexx 55 add rgb
Crucial P1 500 GB
Seagate Barracuda 2 TB
Deepcool DA700 Bronze
Deepcool Gammax 400
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×