Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

S7 edge black screen of death 😢

Go to solution Solved by Nerdom,

Are you able to get into safe mode, or the bootloader? If you can't its probably hardware damage (maybe the screen), but if you can it's probably a software issue. If it is a software issue you might be able to reinstall or rollback android.

My S7 edge was stuck with a black screen and a blinking notification LED and was unresponsive to any buttons so I was unable to restart the phone. 

 

I let the battery drain so that I could restart it then the screen showed colourful lines

 

What is happening 😢 

20200921_214331.jpg

Link to post
Share on other sites

Are you able to get into safe mode, or the bootloader? If you can't its probably hardware damage (maybe the screen), but if you can it's probably a software issue. If it is a software issue you might be able to reinstall or rollback android.

R9 3900x, 32gb 3200mhz corsair dominator RGB, 1070Ti Founders Edition, HP 512GB PCIe M.2 SSD

Link to post
Share on other sites
16 minutes ago, Nerdom said:

Are you able to get into safe mode, or the bootloader? If you can't its probably hardware damage (maybe the screen), but if you can it's probably a software issue. If it is a software issue you might be able to reinstall or rollback android.

I was able to start the phone up normally just now and transfer some important files out before the screen got stuck for awhile then the phone restarted but it got stuck while starting up. 

 

I will try to get into safemode after the battery drains again because it won't respond to me holding down any buttons. 

16006994572931049242347.jpg

Link to post
Share on other sites

After a few times of the phone crashing in safe mode, the installing system update screen poped out which ended with a dead android with "no command" written below it. Right after that the phone restarted normally and has been working without any problems till now. 

 

I only notice that the themes has been set back to default. 

 

Hopefully the phone stays ok

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×