Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Speakers making an annoying sound

Hello, I am have been using the Logitech Z506 speakers for a couple years now and last night I suddenly started hearing an annoying whining sound. The sound plays on the 4 speakers without the volume controller (the 4 unplugged ones at the bottom). I have attached a recording of the center speaker when it is plugged in and would appreciate any input on fixing or replacing the speakers. The sound continues even when the speakers are not plugged into any devices and I have tried using a different power socket too but the results have been the same.

20200914_101421.jpg

Noise.mp3

Link to post
Share on other sites

Ah, I've seen this before.  That sound is Cher's music, which is probably playing in a background tab unbeknownst to you.  

Alrighty, I've made a funny, now for the serious advice:

Make sure your audio cable isn't passing by any power cables or outlets or any other source of electrical interference.  I get that a lot with my subwoofer.  It can even happen if the audio cable is coiled up on itself.  If you're able to manipulate the cable to get it to stop making the noise, then you can look into getting a better shielded cable to solve it more reliably (or you can just work it like the analog antennas of yore whenever the interference comes back)

#Muricaparrotgang

 

Folding@Home Stats | Current PC Loadout:

Small                        Bigger				Biggerer				Biggest
Fractal Design Focus G       NZXT H1				Lian LI O11 Dynamic XL			Fractal Design Meshify C
FX-8320                      Ryzen 3 3200G			Ryzen 5 3600				Ryzen 7 3700X
120mm AIO                    120mm AIO				Custom 280mm loop			Noctua NH-D15
A motherboard                ASRock B450 mobo			MSI x570 mobo				MSI x570 mobo
16gb DDR3                    16gb DDR4 @ 3200			16gb DDR4 @ 3200			16gb DDR4 @ 3600
a melange of HDDs/SSDs       WD 1tb m.2				WD 500gb m.2				WD 1tb m.2/2tb HDD
PNY GTX 1070 x2              GTX 1070				GTX 1070 FE				MSI RTX 2080 TI
some 650w PSU                650W SFX-L 80+ Gold		MSI RTX 2080 Super			EVGA SuperNova 750w 80+ GOLD 
								Corsair RM850x 80+ GOLD

 

Link to post
Share on other sites
9 hours ago, Rybo said:

Ah, I've seen this before.  That sound is Cher's music, which is probably playing in a background tab unbeknownst to you.  

Alrighty, I've made a funny, now for the serious advice:

Make sure your audio cable isn't passing by any power cables or outlets or any other source of electrical interference.  I get that a lot with my subwoofer.  It can even happen if the audio cable is coiled up on itself.  If you're able to manipulate the cable to get it to stop making the noise, then you can look into getting a better shielded cable to solve it more reliably (or you can just work it like the analog antennas of yore whenever the interference comes back)

Haha I tried unplugging my audio cable too, and the sound was still there! I straightened out one of my cables and the sound is still there as well :(

Link to post
Share on other sites
1 hour ago, Aiien79 said:

Haha I tried unplugging my audio cable too, and the sound was still there! I straightened out one of my cables and the sound is still there as well :(

Unplugging doesn't necessarily work: all that does is expose the bare lead that's *made* to carry electrical signals.  

PS: I'm by no means trying to imply that this is definitely the issue, and if you've never had the issue before and didn't rearrange your system before it started happening, it probably isn't the issue.  But I'd hate for you to tear your speakers down and rebuild them for this simple solution to have turned out to be the actual problem.  

#Muricaparrotgang

 

Folding@Home Stats | Current PC Loadout:

Small                        Bigger				Biggerer				Biggest
Fractal Design Focus G       NZXT H1				Lian LI O11 Dynamic XL			Fractal Design Meshify C
FX-8320                      Ryzen 3 3200G			Ryzen 5 3600				Ryzen 7 3700X
120mm AIO                    120mm AIO				Custom 280mm loop			Noctua NH-D15
A motherboard                ASRock B450 mobo			MSI x570 mobo				MSI x570 mobo
16gb DDR3                    16gb DDR4 @ 3200			16gb DDR4 @ 3200			16gb DDR4 @ 3600
a melange of HDDs/SSDs       WD 1tb m.2				WD 500gb m.2				WD 1tb m.2/2tb HDD
PNY GTX 1070 x2              GTX 1070				GTX 1070 FE				MSI RTX 2080 TI
some 650w PSU                650W SFX-L 80+ Gold		MSI RTX 2080 Super			EVGA SuperNova 750w 80+ GOLD 
								Corsair RM850x 80+ GOLD

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×