Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Fixed...? Gigabyte GPU Constant white power LED

I've bought a 2nd hand RTX 2070 to replace my GTX 1070, everything was working prefectly but I've got a briiiiight white power LED on the RTX 2070.

 

The card is a Gigabyte Windforce RTX 2070 8g, but not important as the problem may apply to all Gigabyte/Aorus cards.

I'm listing all attempts I've tried and failed so you may get away with these steps:

 

At1: use an eraser to clean up potential dust build ups on PCIE pins (gentally) - fail

At2: download Gigabyte lighting software to find the LED switch - fail

At3: download Gigabyte AORUS ENginE, AORUS eXTrEMe and find the LED switch - fail

At4: download Nvidia LED Visualize - fail

At5: re flash a BIOS - fail but bios may be updated

At6: re install Nvidia driver - skipped as I don't think thats related

At7: unplug and plug power pins on graphics card - tried 6 times, all failed

At8: move the GPU to a different slot - fail but RGB text has lighten up

 

At9: plug PCIE power cable to a different slot on power supply (having a seasonic M12II, fully modular) - succeeded, for a day, led light up again at night

At10: the next day, problem disappeared again... Tried to wiggle the power cable around while system is on - no issue

At11: checked HWiNFO, there's the screenshot when LED are off:

259640625_firsttesthwinfostable.png.76bf5af993bc36b811a1674a147440dc.png

At12: checked people discusses about M12II EVO, no undervolt issues, but it doesn't not support C6, C7 power states, which shouldn't cause my problem

 

AT13: changed power supply cable back to original slot, still can't reproduce the issue, I'll try a not full plugged in HDMI cable later

Link to post
Share on other sites
12 minutes ago, iavoe said:

how does that even fixed my problem? Weird huh?

im assuming it's the LED at the PCIE power connector to tell you it's connected correctly or not

 

though... idk how that would make it go away 🤔

Things I need help with:

Spoiler

none atm

 

I hate Intel's pricing, Ryzen's weird quirks, Nvidia's pricing, and Radeon GPUs in general

 

Spoiler

 

Products I like:

Spoiler

Sony Xperia Z1 / Z2 / 10 ii, Asus Strix 970 / 1070, Samsung SSD, WD HDD, Corsair PSUs (AX, RM, CX(grey)), GeForce GPU, NZXT N450/S340, be quiet! Coolers, G.Skill Trident RAM, Logitech M525, Logitech G440, Razer Deathadder Elite

 

Products I hate:

Spoiler

Xperia Z3, XiaoMi 5c, Radeon GPUs, Razer Audio Products, any bloatwares

 

Companies I absolutely adore: (and hope it stays that way)

Spoiler

be quiet! - sent me AM4 mounting for my DRP3 even though it's way past the timeframe stated, no questions asked

Corsair - very good RMA experience, absolutely recommend

 

Companies I hate:

Spoiler

Nvidia, Intel, Apple, TMT (Thundermatch, a retailer)

 

Personal Blacklisted Companies:

Spoiler

Acer: shit tier quality products, shit tier customer service thus far, they "tried" to solve my issue but they arent really doing anything but delaying and delaying. (on-going case since July)

Gigabyte: horrible customer service (gigabyte had literally 0 customer service, asked me to go to retailer with NO WAY to email them about a question) but at least they fixed my shit in ONE MONTH (would probably take me 1 hour to fix if they let me email them)

XiaoMi Phones: built like a tank but the software is buggy as all hell

Seagate HDD: had too many dead seagate drives

Kingston SSD: 300V controller swap thingy

Razer (except their mouse)

 

Remember, just because I had good/bad experiences with these companies/product, doesn't mean you will have similar experiences too. I would still recommend these products if they made sense for your needs, but I'll add a disclaimer of my experience if it's relevant. Feel free to DM me asking why they are where they are.

 

 

Link to post
Share on other sites
3 minutes ago, Moonzy said:

im assuming it's the LED at the PCIE power connector to tell you it's connected correctly or not

 

though... idk how that would make it go away 🤔

 

My thought as well.

Only thing I could think of is the modular socket on the PSU side is faulty.

Moving it to another socket, that's NOT faulty, and everything works.

Intel Z390 Rig ( *NEW* Primary )

Intel X99 Rig (Officially Decommissioned, Dead CPU returned to Intel)

  • i7-8086K @ 5.1 GHz (still tweaking) -- i7-6800K
  • Gigabyte Z390 Aorus Master -- ASUS X99 Deluxe
  • Sapphire NITRO+ RX 5700 XT Special Edition -- 2x Sapphire NITRO R9-Fury in Crossfire
  • 32GB G.Skill TridentZ DDR4-3000 CL14 (16GB TridentZ RGB + 16GB Red/Black TridentZ)
  • SanDisk 480 GB SSD + 1TB Samsung 860 EVO + 1TB Intel 660p NVMe
  • EVGA SuperNOVA 850W P2 + Red/White CableMod Cables
  • Phanteks Enthoo Luxe Tempered Glass Edition
  • Ekwb Custom loop
  • Logitech G502 Proteus Spectrum + Corsair K70 (Red LED, anodized black, Cheery MX Browns)

Intel Z97 Rig (Secondary)

  • Intel i5-4690K 4.8 GHz
  • ASUS ROG Maximus VII Hero Z97
  • Sapphire Vapor-X HD 7950 EVGA GTX 1070 SC Black Edition ACX 3.0
  • 20 GB (8GB X 2 + 4GB X 1) Corsair Vengeance DDR3 1600 MHz
  • Corsair A50 air cooler  NZXT X61
  • Crucial MX500 1TB SSD + SanDisk Ultra II 240GB SSD + WD Caviar Black 1TB HDD + Kingston V300 120GB SSD [non-gimped version]
  • Antec New TruePower 550W EVGA G2 650W + White CableMod cables
  • Cooler Master HAF 912 White NZXT S340 Elite w/ white LED stips

AMD 990FX Rig (Decommissioned)

  • FX-8350 @ 4.8 / 4.9 GHz (given up on the 5.0 / 5.1 GHz attempt)
  • ASUS ROG Crosshair V Formula 990FX
  • 12 GB (4 GB X 3) G.Skill RipJawsX DDR3 @ 1866 MHz
  • Sapphire Vapor-X HD 7970 + Sapphire Dual-X HD 7970 in Crossfire  Sapphire NITRO R9-Fury in Crossfire *NONE*
  • Thermaltake Frio w/ Cooler Master JetFlo's in push-pull
  • Samsung 850 EVO 500GB SSD + Kingston V300 120GB SSD + WD Caviar Black 1TB HDD
  • Corsair TX850 (ver.1)
  • Cooler Master HAF 932

 

<> Electrical Engineer , B.Eng <>

<> Electronics & Computer Engineering Technologist (Diploma + Advanced Diploma) <>

<> Electronics Engineering Technician for the Canadian Department of National Defence <>

Link to post
Share on other sites
1 hour ago, -rascal- said:

 

My thought as well.

Only thing I could think of is the modular socket on the PSU side is faulty.

Moving it to another socket, that's NOT faulty, and everything works.

Maybe that slot was used for a long time to power my gtx 970, 1070 and now 2070. So it somehow glitched

Link to post
Share on other sites

uhhh the light it's back, I'll try fix it tomorrow...

1: open HWMonitor and look for voltages, it might be wrong - done for the LED off situation

2: windows10 pcie power plan - it is full power for PCIE slots

3: switch a power cable, it might be old - tried to wiggle this cable around but LED won't light up

 

This is really strange because I never had an issue with power on my GTX 1070, and it really doesn't look like the power supply is not right

Link to post
Share on other sites

Check later: RTX 2070 instantaneous boot voltage/wattage and R5 2600 1.37v OC wattage

Link to post
Share on other sites

I've switched the powercable on powersupply back, I'm still unable to recreate the problem, I guess it was only a glitch...

Link to post
Share on other sites

I've switched powersupply-end cable slot back, and I still didn't reproduce the issue, the ladt try could be about the hdmi cable was not fully plugged in

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×