Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't update to Windows 10 2004 via Update Assitant or Media Creation Tool

When I tried to update to Windows 10 2004 (I wanna give WSL2 a go), I get stuck at 99% & 31% with Update Assistant & Media Creation Tool, respectively.

 

Any idea what I should fix?

"Love always happens without warning. At that time, the gears of fate will start spinning. Just like the hands of a clock, two people’s hearts will separate and meet again. Eventually, they reunite."  - Konjiki no Yami (To Love-Ru)

 

Desktop

Y4M1: Intel Core i5-6500 | MSI H170 Gaming M3 | Zotac GeForce GTX 1060 AMP! Edition | 16GB Kingston HyperX Fury Black  | 256GB Samsung 850 Pro SSD +  480GB SanDisk SSD Plus + 2TB Seagate Barracuda 7200RPM HDD + 4TB Western Digital Black | Fully modular EVGA SuperNOVA NEX 650W 80+ Gold ATX PSU | Zalman Z11 NEO ATX mid tower case | Acer 27" GF276 75Hz + 24" S41HL 60Hz Monitor | G.Skill RIPJAWS MX780 |  G.Skill RIPJAWS KM780 MX | Kubuntu (with MATE & Unity DE)

-------------------------------

Mobile devices

Kuroka: Lenovo Z40 laptop with Kubuntu + 250GB Samsung 850 EVO + 8GB RAM (total 16GB)

Rei: Xperia Z5 Compact with LineageOS

Xenia: Moto Z with AICP

Airi: Samsung Galaxy S4 with Resurrection Remix

Yuki: 5th generation iPod touch

Relic: IBM Thinkpad T42 with Lubuntu (upgraded with 2GB RAM)

Sylver: Lenovo Z510 laptop with Solus Plasma

Link to post
Share on other sites
4 minutes ago, YamiYukiSenpai said:

When I tried to update to Windows 10 2004 (I wanna give WSL2 a go), I get stuck at 99% & 31% with Update Assistant & Media Creation Tool, respectively.

 

Any idea what I should fix?

I had a similar issue where it would end up crashing and reverting back. I solved it by reformatting WITH 2004... thankfully my OS drives have nothing of importance on them so it’s relatively easy for me to do. Most are not in the same situation. I am not really sure what else you can try :/

Rig: i9 9900k @ 5Ghz - - Z390 Auros Elite  - - EVGA RTX 2080 XC Ultra @ 2025Mhz - - 4x8GB Vengeance Pro 3000Mhz @ 3600MHz - - Samsung 950 Pro 512 NVMe Boot + Main Programs - - Samsung 830 Pro 256 RAID 0 Lightroom + Photo work - - WD Blue 1 TB SSD for Games - - Corsair RM650i - - Sound BlasterX EA-5 - - EK Supremacy Evo - - XT45 X-Flow 420 + UT60 280 rads - - EK Full Cover GPU Block - - EK XRES RGB PWM - - Fractal Define S2 - - Acer Predator X34 -- Logitech G502 - - Logitech G710+ - - Logitech Z5500 - - Steel Series QcK XXL

 

Headphones/amp/dac: Schiit Lyr 3 - - Fostex TR-X00 - - Sennheiser HD 6xx

 

Homelab/ Media Server: ESXi 6.5 - - 250 GB SSD for VM's/ESXi boot - - FreeNAS 11.3-U2 - - HPE Proliant ML10 Gen 9 backbone - - i3 6100 - - 28 GB ECC - - 10x4 TB WD Red RAID Z2 - - Corsair 750D - - Corsair RM650i - - Dell H310 6Gbps SAS HBA - - Intel RES2SC240 SAS Expander

 

White Lightning (original full watercooled build) - Homelab / Media Server - The Blue Beast (my car and other expensive hobby...) - iPhone Xs - 2018 MacBook Air

Link to post
Share on other sites

Delete SoftwareDistribution folder and try again ?

CPU : Xeon E5-1680 v2 @ 4,3 GHz + Hydronaut + TRVX + 2x Delta 38mm PWM
MB : Sabertooth X79 (BIOS 4801 + NVMe mod + uCode update)
RAM : 8x A-Data DDR3 XPG 2000X 2GB @ 1868MHz CL8.9.8.24 CR2T, Quad Channel.
GPU : ASUS GTX 1080 (FE)
M.2/HDD : Samsung SM961 256GB (NVMe/OS) + RAID0 2x WD10EZEX (rev. 2013) + HGST Ultrastar 7K6000 6TB
Link to post
Share on other sites
14 minutes ago, YamiYukiSenpai said:

I get stuck at 99% & 31% with Update Assistant & Media Creation Tool,

When you get stuck at the Media Creation Tool, is that when making an upgrade drive, or while trying to upgrade your computer?

 

Honestly, I'd recommend staying away from 2004 for now.  Every time Microsoft releases a new build, it has major problems that need to be worked out, and 2004 is no exception.  If you really want it though, my first suggestion would be to run Disk Cleanup as administrator and delete all the Windows Update stuff.

Make sure to quote or tag me (@JoostinOnline) or I won't see your response!

PSU Tier List  |  The Real Reason Delidding Improves Temperatures"2K" does not mean 2560×1440 

Link to post
Share on other sites

i'll suggest to you to either wait or install it on a second drive or something, 2004 is still quite buggy and i had a bunch of issues until i went back to 1909 so i'd stay away for now. 

Phone: iPhone SE 2020 | 64GB iOS
Laptop: HP EliteBook 9470m | Core i5 3437U | 16GB RAM | 250GB SSD | Windows 10 & Ubuntu 20.10

PC: Supermicro X8DT3 | 2x Xeon X5650 | R9 290X | 32GB RAM500GB SSD | Bitfenix Whisper 850W | Windows 10

Link to post
Share on other sites
15 minutes ago, agent_x007 said:

Delete SoftwareDistribution folder and try again ?

I think I gave that a whirl a few weeks back, but I can't remember.  I'll try that again.

 

5 minutes ago, JoostinOnline said:

When you get stuck at the Media Creation Tool, is that when making an upgrade drive, or while trying to upgrade your computer?

Upgrading my PC

"Love always happens without warning. At that time, the gears of fate will start spinning. Just like the hands of a clock, two people’s hearts will separate and meet again. Eventually, they reunite."  - Konjiki no Yami (To Love-Ru)

 

Desktop

Y4M1: Intel Core i5-6500 | MSI H170 Gaming M3 | Zotac GeForce GTX 1060 AMP! Edition | 16GB Kingston HyperX Fury Black  | 256GB Samsung 850 Pro SSD +  480GB SanDisk SSD Plus + 2TB Seagate Barracuda 7200RPM HDD + 4TB Western Digital Black | Fully modular EVGA SuperNOVA NEX 650W 80+ Gold ATX PSU | Zalman Z11 NEO ATX mid tower case | Acer 27" GF276 75Hz + 24" S41HL 60Hz Monitor | G.Skill RIPJAWS MX780 |  G.Skill RIPJAWS KM780 MX | Kubuntu (with MATE & Unity DE)

-------------------------------

Mobile devices

Kuroka: Lenovo Z40 laptop with Kubuntu + 250GB Samsung 850 EVO + 8GB RAM (total 16GB)

Rei: Xperia Z5 Compact with LineageOS

Xenia: Moto Z with AICP

Airi: Samsung Galaxy S4 with Resurrection Remix

Yuki: 5th generation iPod touch

Relic: IBM Thinkpad T42 with Lubuntu (upgraded with 2GB RAM)

Sylver: Lenovo Z510 laptop with Solus Plasma

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×