Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Acer Predator X27 HDR problem

Hi guys, I just recently got an Acer Predator X27P and I have had it for two weeks now with zero issues and no defects that I have noticed.

 

I have been playing AC Odyssey in HDR at 98hz and I had zero issues and everything seemed to look how it was supposed to even in the picture for HDR where you set up the luminance and paper white. Then today I went onto the game and have noticed this weird set of pink pixels in the HDR setup picture. So I restarted the game and went back to the HDR setup again and the image was back to normal with no issues but looked a bit dull. Then I went into the game and looked again and the pink and blue pixels appeared again. The sun also looked weird compared to before as well.

 

I have checked for stuck pixels on my desktop and there is none. I tried changing the DisplayPort cable to a brand new one and the same thing is also happening. I reset the monitor to its default OSD settings as well. I literally haven’t changed anything to do with the monitor or it’s settings since the day I got it after I set it up apart from the ambient lighting and turned on auto black level.

 

One thing that I think may have broken it though was the other night when there was a thunderstorm and I turned the monitor and my setup off and then unplugged the extension lead from the wall and then plugged it back in the next day once the storm had passed and the monitor turned on straight away with my other monitor even though I had turned them off before I unplugged. I think that may have caused this to happen but I am probably wrong. Either that or the game has something wrong with its HDR but like I said the past weeks I haven’t noticed any problems like that. 
 

Sorry if this is quite long I just thought I’d explain everything. Please look at the pictures I have put to see what I am on about. I also verified the game files to see if it would fix anything but it didn’t. 

Edit: I am going to add some pictures of how it should look when I load up into the start menu of the game before continuing into story mode where it messes up. If you look in the first two images you can see that everything looks wrong compared to the last two images. Any answer as to what you think may be wrong would be very helpful.

 

Thanks

B4DFB91C-62EC-47EE-8DD8-BF73F907FB45.jpeg

E8D601AA-1EB6-4278-8960-47436806910B.jpeg

F9127B57-5716-4117-9EA8-92B5043EB965.jpeg

38C7C8BA-093D-4DAA-B04F-39B6E86F8B06.jpeg

Link to post
Share on other sites

it's not stuck pixels, just hdr being weird and display colors that are out of range, happens in some games, happened to me on shadow of war. I'm not sure whether this is a problem with how windows handle hdr or the game. The purple dots are way out of range and the blues in the sky is kinda off too. Rest Assure your monitor is not broken in any way.

 

You can get this problem for sure if you play in fullscreen windowed mode and enable hdr both on desktop and in-game. For games that have poor hdr implementation i recommend playing in full screen windowed, turn off hdr in-game, and adjust brightness/contrast in game.

 

 

9900k 1.36v max 1.3v avx 5.2ghz-1avx 4.8 cache 95C 175w 1.05v 4.4ghz 95w 55C R20/blender temps ll D15 ll Z390 taichi ult 1.60 bios ll gskill 2x8gb 16-16-16-34-280-24 ddr3866  bdie 1.42v dram 1.22v io/sa (anything higher needs more voltage on all (dram/io/sa) ll EVGA 2080 ti XC 1995//7600 power limited 79C max, stock voltage (bad ocer) ll 2x samsung 860 evo 500gb raid 0 ll 500gb nvme 970 evo ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (using at 4:4:4 98)

 

old rig 8600k d15 evga 1080 ti hybrid  z370 extreme 4 2x8gb ddr3000 512gb nvme evo+ 860 evo 500gb raid 0 evga p2 1000w 

Link to post
Share on other sites
6 minutes ago, xg32 said:

it's not stuck pixels, just hdr being weird and display colors that are out of range, happens in some games, happened to me on shadow of war. I'm not sure whether this is a problem with how windows handle hdr or the game. The purple dots are way out of range and the blues in the sky is kinda off too. Your monitor is not broken in any way.

 

You can get this problem for sure if you play in fullscreen windowed mode and enable hdr both on desktop and in-game. For games have poor hdr implementation i recommend playing in full screen windowed, turn off hdr in-game, and adjust brightness/contrast in game.

 

 

Okay thanks I have been paranoid that I just bought this monitor and all of a sudden I start seeing this in the sample image. I was playing in HDR on full screen the entire time with it turned on in windows and I wasn’t getting this before. I would try full screen borderless because I have two monitors but HDR on AC becomes unavailable. Also when you say to adjust the HDR without it being enabled in windows do you mean the peak white nits option in the OSD?

 

One more thing I have noticed as well is when I move into a darker area on the game such as a cave and then look at the reference image it gets rid of most of the weird image but keeps one tiny pink dot on one of the clouds.

Link to post
Share on other sites
2 minutes ago, Simon Slays said:

Okay thanks I have been paranoid that I just bought this monitor and all of a sudden I start seeing this in the sample image. I was playing in HDR on full screen the entire time with it turned on in windows and I wasn’t getting this before. I would try full screen borderless because I have two monitors but HDR on AC becomes unavailable. Also when you say to adjust the HDR without it being enabled in windows do you mean the peak white nits option in the OSD?

 

One more thing I have noticed as well is when I move into a darker area on the game such as a cave and then look at the reference image it gets rid of most of the weird image but keeps one tiny pink dot on one of the clouds.

I just realised what you actually said. That it happens when in full screen mode with windows HDR enabled. I thought you was suggesting to play in full screen borderless, my bad.

Link to post
Share on other sites
5 minutes ago, Simon Slays said:

Okay thanks I have been paranoid that I just bought this monitor and all of a sudden I start seeing this in the sample image. I was playing in HDR on full screen the entire time with it turned on in windows and I wasn’t getting this before. I would try full screen borderless because I have two monitors but HDR on AC becomes unavailable. Also when you say to adjust the HDR without it being enabled in windows do you mean the peak white nits option in the OSD?

 

One more thing I have noticed as well is when I move into a darker area on the game such as a cave and then look at the reference image it gets rid of most of the weird image but keeps one tiny pink dot on one of the clouds.

The monitor with hdr completely disabled has a very low peak brightness with the fald disabled. so i always keep hdr on in desktop and play in windowed/fullscreen for most game (metro only launches fullscreen so thats an exception), i then adjust the brightness down while hdr is on on desktop.

 

Once a game launches in full screen with "out of range colors/dots it stays that way until a restart on the game.

9900k 1.36v max 1.3v avx 5.2ghz-1avx 4.8 cache 95C 175w 1.05v 4.4ghz 95w 55C R20/blender temps ll D15 ll Z390 taichi ult 1.60 bios ll gskill 2x8gb 16-16-16-34-280-24 ddr3866  bdie 1.42v dram 1.22v io/sa (anything higher needs more voltage on all (dram/io/sa) ll EVGA 2080 ti XC 1995//7600 power limited 79C max, stock voltage (bad ocer) ll 2x samsung 860 evo 500gb raid 0 ll 500gb nvme 970 evo ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (using at 4:4:4 98)

 

old rig 8600k d15 evga 1080 ti hybrid  z370 extreme 4 2x8gb ddr3000 512gb nvme evo+ 860 evo 500gb raid 0 evga p2 1000w 

Link to post
Share on other sites
7 minutes ago, Simon Slays said:

I just realised what you actually said. That it happens when in full screen mode with windows HDR enabled. I thought you was suggesting to play in full screen borderless, my bad.

thats what im suggesting, it works for me, there are more problems with the color ranges when not playing in windowed mode, my typical settings are hdr on in windows, windowed fullscreen, mostly 4k, sometimes 1440p if frame rates are low, monitor brightness 140nits, nvidia control panel 4k 98hz rgb (444 makes me dizzy for some reason), then i further adjust brightness in-game settings til my eyes are comfortable. The way the FALD is implemented requires u to have hdr on on desktop. Otherwise it just looks very dim.

9900k 1.36v max 1.3v avx 5.2ghz-1avx 4.8 cache 95C 175w 1.05v 4.4ghz 95w 55C R20/blender temps ll D15 ll Z390 taichi ult 1.60 bios ll gskill 2x8gb 16-16-16-34-280-24 ddr3866  bdie 1.42v dram 1.22v io/sa (anything higher needs more voltage on all (dram/io/sa) ll EVGA 2080 ti XC 1995//7600 power limited 79C max, stock voltage (bad ocer) ll 2x samsung 860 evo 500gb raid 0 ll 500gb nvme 970 evo ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (using at 4:4:4 98)

 

old rig 8600k d15 evga 1080 ti hybrid  z370 extreme 4 2x8gb ddr3000 512gb nvme evo+ 860 evo 500gb raid 0 evga p2 1000w 

Link to post
Share on other sites
5 minutes ago, xg32 said:

thats what im suggesting, it works for me, there are more problems with the color ranges when not playing in windowed mode, my typical settings are hdr on in windows, windowed fullscreen, mostly 4k, sometimes 1440p if frame rates are low, monitor brightness 140nits, nvidia control panel 4k 98hz rgb, then i further adjust brightness in-game settings til my eyes are comfortable. The way the FALD is implemented requires u to have hdr on on desktop. Otherwise it just looks very dim.

How are you able to adjust your brightness to 140 nits whilst having HDR enabled in windows? Whenever I try to adjust my nits in the OSD it just says “this function is not available” and by default when I turn on HDR in windows it sets itself to 80 nits. When I turn off HDR in windows though I am able to adjust the nits for SDR content.

Link to post
Share on other sites
1 minute ago, Simon Slays said:

How are you able to adjust your brightness to 140 nits whilst having HDR enabled in windows? Whenever I try to adjust my nits in the OSD it just says “this function is not available” and by default when I turn on HDR in windows it sets itself to 80 nits. When I turn off HDR in windows though I am able to adjust the nits for SDR content.

i adjusted it in sdr mode then turned on hdr, not sure how much of that carries over, you can further adjust it in nvidia control panel, not sure about amd cards though. The gamma isn't perfect in lower brightness hdr, but it's good on the eyes and everything looks good.

9900k 1.36v max 1.3v avx 5.2ghz-1avx 4.8 cache 95C 175w 1.05v 4.4ghz 95w 55C R20/blender temps ll D15 ll Z390 taichi ult 1.60 bios ll gskill 2x8gb 16-16-16-34-280-24 ddr3866  bdie 1.42v dram 1.22v io/sa (anything higher needs more voltage on all (dram/io/sa) ll EVGA 2080 ti XC 1995//7600 power limited 79C max, stock voltage (bad ocer) ll 2x samsung 860 evo 500gb raid 0 ll 500gb nvme 970 evo ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (using at 4:4:4 98)

 

old rig 8600k d15 evga 1080 ti hybrid  z370 extreme 4 2x8gb ddr3000 512gb nvme evo+ 860 evo 500gb raid 0 evga p2 1000w 

Link to post
Share on other sites
1 minute ago, xg32 said:

i adjusted it in sdr mode then turned on hdr, not sure how much of that carries over, you can further adjust it in nvidia control panel, not sure about amd cards though. The gamma isn't perfect in lower brightness hdr, but it's good on the eyes and everything looks good.

I’m using the ASUS ROG RTX 2080 Ti not an AMD card. I just wish that my monitor was working the same way it was when I got it because I wasn’t having these issues until today. I thought that my monitor had an issue when using HDR. Also I don’t think it will carry over from SDR to HDR because it locks most of my OSD picture settings when I enable HDR so it must be doing its own thing.

Link to post
Share on other sites

Do you have DP YCbCr sRGB enabled whilst HDR is on? I don’t even know what this setting does. When I turn it off it doesn’t seem to change anything.

Link to post
Share on other sites
50 minutes ago, Simon Slays said:

Do you have DP YCbCr sRGB enabled whilst HDR is on? I don’t even know what this setting does. When I turn it off it doesn’t seem to change anything.

in simpler terms thats 422, full rgb is almost 444, basically it's chroma sampling that takes out some colors to reduce bandwidth so u can go higher than 98hz on 4k hdr.

 

The max on the displayport 1.4 is 422 144hz hdr/444 120hz sdr/444 98hz hdr (these are the only 3 settings i recommend) i use 444 98hz most of the time, 422 isn't very noticebale in games other than slight discolorations and i used it for 144hz on poe and warframe last year. 422 makes text blurry on desktop, among other things.

 

Theres a new tech called DSC (?) that uses compression to lower bandwidth so some monitors can use 4k 144hz 444 instead of 422, but no hdr1000 monitor that supports it yet, soon tm.  displayport 2.0 also doesnt have bandwidth problems at 4k/144hz but that won't be widespread til 2022.

9900k 1.36v max 1.3v avx 5.2ghz-1avx 4.8 cache 95C 175w 1.05v 4.4ghz 95w 55C R20/blender temps ll D15 ll Z390 taichi ult 1.60 bios ll gskill 2x8gb 16-16-16-34-280-24 ddr3866  bdie 1.42v dram 1.22v io/sa (anything higher needs more voltage on all (dram/io/sa) ll EVGA 2080 ti XC 1995//7600 power limited 79C max, stock voltage (bad ocer) ll 2x samsung 860 evo 500gb raid 0 ll 500gb nvme 970 evo ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (using at 4:4:4 98)

 

old rig 8600k d15 evga 1080 ti hybrid  z370 extreme 4 2x8gb ddr3000 512gb nvme evo+ 860 evo 500gb raid 0 evga p2 1000w 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×