Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

RX5700 xt driver bug

Go to solution Solved by cried22,
1 hour ago, Gohardgrandpa said:

@Zomeguy

I have the same fan curve issue. I get it amd is cheaper but damn the software is horrible. I know nvidia has had issues before too but I’ve never had a issue with a nvidia card and I went amd this time because it was cheaper. I won’t be doing that again. 

Agreed with this. The few dollars saved is not worth all the issues.

So I've been having all sorts of issues with the adrenaline software and saw I could install just the driver and not all the amd garbage software with it. I installed just the driver by going to device manager, display adapter then pointed where to find the driver to install it. I get a random screen flicker now, I'd say every 10 or so seconds that I didn't have before. I did DDU once and it is still doing it. Any ideas on what to do now?

 

My issue with the adrenaline software has been no matter what driver version I use I get game crashes and black screens requiring a total system restart and it happens at the worst time, normally mid game.

CPU:  Intel 10700k  5.2ghz @1.3V

Mobo: Msi Z490 Gaming edge wifi 

Cooler: Evga clc 360mm aio

Fans: 9 Corsair sp120 rgb pro 

GPU:  Evga Rtx 3070 ftw3 ultra gaming 

Ram: 32gb Corsair rgb pro ddr4 3600mhz 

Case: Lian li pc011 

PSU: Corsair Rm850x

Storage: 2Tb Samsung Nvme ssd

Display: Monoprice dark matter 34inch 3440x1440 144hz

Mouse: Logitech G703

Keyboard: Razer ornata chroma 

 

Link to post
Share on other sites

why did you install it form device manger. That was a mistake. Do a DDU again and updtae the drivers via AMD's website.

QUOTE ME  FOR ANSWER.

 

Main PC:

Spoiler

|Ryzen 7 3700x, OC to 4.2ghz @1.3V, 67C, or 4.4ghz @1.456V, 87C || Asus strix 5700 XT, +50 core, +50 memory, +50 power (not a great overclocker) || Asus Strix b550-A || G.skill trident Z Neo rgb 32gb 3600mhz cl16-19-19-19-39, oc to 3733mhz with the same timings || Cooler Master ml360 RGB AIO || Phanteks P500A Digital || Thermaltake ToughPower grand RGB750w 80+gold || Samsung 850 250gb and Adata SX 6000 Lite 500gb || Toshiba 5400rpm 1tb || Asus Rog Theta 7.1 || Asus Rog claymore || Asus Gladius 2 origin gaming mouse || Monitor 1 Asus 1080p 144hz || Monitor 2 AOC 1080p 75hz || 

Currently selling:

Spoiler

Ryzen 5 3400G || Gigabyte b450 S2H || Hyper X fury 2x4gb 2666mhz cl 16 ||Stock cooler || Antec NX100 || Silverstone essential 400w || Transgend SSD 220s 480gb ||

Currently working on:

Spoiler

| i3 9100F || Msi Ventus gtx 1050 TI || MSI Z390 A-Pro || Kingston 1x16gb 2400mhz cl17 || Stock cooler || Kolink Horizon RGB || Silverstone essential 400w || Pny CS900 120gb ||

 

 

Ask me anything :)

 

 

 

 

 

Link to post
Share on other sites
10 hours ago, Gohardgrandpa said:

So I've been having all sorts of issues with the adrenaline software and saw I could install just the driver and not all the amd garbage software with it. I installed just the driver by going to device manager, display adapter then pointed where to find the driver to install it. I get a random screen flicker now, I'd say every 10 or so seconds that I didn't have before. I did DDU once and it is still doing it. Any ideas on what to do now?

 

My issue with the adrenaline software has been no matter what driver version I use I get game crashes and black screens requiring a total system restart and it happens at the worst time, normally mid game.

Honestly, it sounds like the graphics card might be the issue. The fact the issue persists across multiple driver versions means its pretty unlikely to be the driver.

 

9 hours ago, SavageNeo said:

why did you install it form device manger. That was a mistake. Do a DDU again and updtae the drivers via AMD's website.

OP said they've tried multiple versions from AMD and get the same result.

Main Rig:-

Ryzen 7 3800X | Asus ROG Strix X570-F Gaming | 16GB Team Group Dark Pro 3600Mhz | Corsair MP600 1TB PCIe Gen 4 | Sapphire 5700 XT Pulse | Corsair H115i Platinum | WD Black 1TB | WD Green 4TB | EVGA SuperNOVA G3 650W | Asus TUF GT501 | Samsung C27HG70 1440p 144hz HDR FreeSync 2 | Windows 10 Pro X64 |

 

Server:-

Intel NUC running Server 2019 + Synology DSM218+ with 2 x 4TB Toshiba NAS Ready HDDs (RAID0)

Link to post
Share on other sites

I have a MSI 5700xt and I have to say AMD's software is pretty bad. The only time I didn't have problems is when I first installed the card on a fresh install of windows. After the first driver update I started having problems with the current biggest issue being the fan curve. The default fan curve isn't aggressive enough in the current heat (won't go above 60%) and the custom fan curve I put in won't save and randomly defaults to the default curve.

 

I've done the DDU and other such things but hasn't fixed the issues. The only thing I haven't done is a fresh install of windows and I really don't want to do that but it's getting to the point where I might try it to see if I can get more stability.

 

It's like they fix one thing and the next driver always breaks something else. I know Nvidia isn't perfect but they have a lot better consistency than AMD.

Link to post
Share on other sites

@Zomeguy

I have the same fan curve issue. I get it amd is cheaper but damn the software is horrible. I know nvidia has had issues before too but I’ve never had a issue with a nvidia card and I went amd this time because it was cheaper. I won’t be doing that again. 

CPU:  Intel 10700k  5.2ghz @1.3V

Mobo: Msi Z490 Gaming edge wifi 

Cooler: Evga clc 360mm aio

Fans: 9 Corsair sp120 rgb pro 

GPU:  Evga Rtx 3070 ftw3 ultra gaming 

Ram: 32gb Corsair rgb pro ddr4 3600mhz 

Case: Lian li pc011 

PSU: Corsair Rm850x

Storage: 2Tb Samsung Nvme ssd

Display: Monoprice dark matter 34inch 3440x1440 144hz

Mouse: Logitech G703

Keyboard: Razer ornata chroma 

 

Link to post
Share on other sites
1 hour ago, Gohardgrandpa said:

@Zomeguy

I have the same fan curve issue. I get it amd is cheaper but damn the software is horrible. I know nvidia has had issues before too but I’ve never had a issue with a nvidia card and I went amd this time because it was cheaper. I won’t be doing that again. 

Agreed with this. The few dollars saved is not worth all the issues.

Link to post
Share on other sites
2 hours ago, cried22 said:

Agreed with this. The few dollars saved is not worth all the issues.

It sucks because the card performs great. It’s all the little dumb stuff that happens that kills the experience for me at least. For a $400 card the performance is great, it stays cool when I apply the fan curve every friggin time 

CPU:  Intel 10700k  5.2ghz @1.3V

Mobo: Msi Z490 Gaming edge wifi 

Cooler: Evga clc 360mm aio

Fans: 9 Corsair sp120 rgb pro 

GPU:  Evga Rtx 3070 ftw3 ultra gaming 

Ram: 32gb Corsair rgb pro ddr4 3600mhz 

Case: Lian li pc011 

PSU: Corsair Rm850x

Storage: 2Tb Samsung Nvme ssd

Display: Monoprice dark matter 34inch 3440x1440 144hz

Mouse: Logitech G703

Keyboard: Razer ornata chroma 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×