Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Half Life 2 (hl2.exe) Freezing. Please Help!

Go to solution Solved by Sephiroth720,
43 minutes ago, ShrimpBrime said:

Right click the game exe and try running it in compatibility mode with W7 or XP.

Wow! So I just thought I would google the issue again and it turns out that it's the MSi Afterburner overlay software... As soon as i closed it Half Life 2 fired right up!. That's insane!

Hi Everyone,

I am currently having a rather frustrating issue with any game that uses the hl2.exe program (Half Life 2, Portal etc.) The game launches and I get around 2 - 3 seconds of the first audio with NO video at all (Usually it would be the man with a tap on the back of his head) and then the game freezes forcing me to quit through the task manager.

 

I have submitted a ticket with Steam support but they've just listed a bunch of launch command options for me to try. I have so far tried the following things to fix-

 

- All OS & Driver updates have been completed.

- I have removed any entry of Half Life 2 from the registry & removed all leftover files from Steam Apps folder, Then clean installed the game again (Please note that I am also having this issue with Portal)

- I have tried all of the launch command options within Steam (-windowed & -32bit etc.) 

- I have tried clicking the "Wait for the program to respond" option when the game freezes

- I have tried "optimizing" the game settings from within nVidia Control panel (it said it had optimized as per usual but did nothing to help the game launching)

- I have installed Half Life 2 & Portal onto another gaming PC that I have with slightly older specs but with the same Windows 10 build and it works flawlessly.

 

PC Specs:

 

CPU: Ryzen 5 3600

AIO: NZXT Kraken Z63

MOBO: Gigabyte Aorus B450 M

RAM: 32GB Cosair Vengeance LPX @ 3000mhz

GPU: RTX 2060 Super 8GB

SSD: Samsung 860 Pro 2TB

 

Any help would be greatly appreciated as this is one of my favourite games and I'm completely unable to play it.

AMD Ryzen 5 3600 | NZXT Kraken Z63 280mm AIO | Gigabyte Aorus M B450 Motherboard | 32GB Corsair Vengeance LPX DDR4 @ 3000mhz  | Samsung 860 Pro 2TB | MSi Geforce RTX 2060 Super Gaming X 8GB | BeQuiet PurePower 11 700W |

Link to post
Share on other sites

Right click the game exe and try running it in compatibility mode with W7 or XP.

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
40 minutes ago, ShrimpBrime said:

Right click the game exe and try running it in compatibility mode with W7 or XP.

No luck. Does the exact same thing. This is a very odd issue.

AMD Ryzen 5 3600 | NZXT Kraken Z63 280mm AIO | Gigabyte Aorus M B450 Motherboard | 32GB Corsair Vengeance LPX DDR4 @ 3000mhz  | Samsung 860 Pro 2TB | MSi Geforce RTX 2060 Super Gaming X 8GB | BeQuiet PurePower 11 700W |

Link to post
Share on other sites
1 minute ago, Sephiroth720 said:

No luck. Does the exact same thing. This is a very odd issue.

Try a reinstall of the game, but locate the file path to a different drive maybe?

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites
43 minutes ago, ShrimpBrime said:

Right click the game exe and try running it in compatibility mode with W7 or XP.

Wow! So I just thought I would google the issue again and it turns out that it's the MSi Afterburner overlay software... As soon as i closed it Half Life 2 fired right up!. That's insane!

AMD Ryzen 5 3600 | NZXT Kraken Z63 280mm AIO | Gigabyte Aorus M B450 Motherboard | 32GB Corsair Vengeance LPX DDR4 @ 3000mhz  | Samsung 860 Pro 2TB | MSi Geforce RTX 2060 Super Gaming X 8GB | BeQuiet PurePower 11 700W |

Link to post
Share on other sites
2 minutes ago, Sephiroth720 said:

Wow! So I just thought I would google the issue again and it turns out that it's the MSi Afterburner overlay software... As soon as i closed it Half Life 2 fired right up!. That's insane!

Ohhh, damn. Good find! 

Glad its working!

- If it ain't broken, don't fix it! - - Your post codes and beep codes in the drop down below -

Spoiler

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×