Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • I was just installing my gpu and I accidentally scratched 2 traces on my mobo.  I haven’t installed the cpu yet so I haven’t powered it up. Does it look like I killed them or will it be fine?

image.jpg

image.jpg

Link to post
Share on other sites
2 minutes ago, FishNuggets01 said:
  • I was just installing my gpu and I accidentally scratched 2 traces on my mobo.  I haven’t installed the cpu yet so I haven’t powered it up. Does it look like I killed them or will it be fine?

image.jpg

image.jpg

Doesn't look like you've cut through them; only way to know for certain is to test the build on the m/board box.

Did you test boot it, before you built in into the case?

WHY NOT...?!

Link to post
Share on other sites

Mine looks way worse but still works, I slipped with a screwdriver and got mine.

i5 8600 - RX580 - Fractal Nano S - 1080p 144Hz

Link to post
Share on other sites

I am junior in highschool so I have been stuck in my house since march, and because of the shortage of pc parts rn they have been slowly coming in. I know that I am comitting a cardinal sin against the pcmr by not testing it to make sure It can post, but I have more than enough time on my hands to take it apart if need be, and this project has been the only thing keeping me sane through all of this. In short, I know I shouldn't, but I really want to start working on it and I have plenty of time on my hands if I need to take it apart and start again.

Link to post
Share on other sites

I probobly shouldn't worry about it to much because it doesn't look too deep, I think they are just the traces for the k/m ports, and it would really suck if i did kill it but it is an 70 dollar matx b450 board, so it could be worse. I am sure it will be fine though, Thank you all!

Link to post
Share on other sites
9 minutes ago, NineEyeRon said:

Mine looks way worse but still works, I slipped with a screwdriver and got mine.

did you end up crossing any of the traces?

Link to post
Share on other sites
10 minutes ago, FishNuggets01 said:

I probobly shouldn't worry about it to much because it doesn't look too deep, I think they are just the traces for the k/m ports, and it would really suck if i did kill it but it is an 70 dollar matx b450 board, so it could be worse. I am sure it will be fine though, Thank you all!

Take it easy from here on in... GL

Did you test boot it, before you built in into the case?

WHY NOT...?!

Link to post
Share on other sites

I love the rare occasions when I get to use this phrase, one of my trademark lines, in a totally helpful, non-ironic way:

 

Only one way to find out!

 

Piece it together on top of the motherboard box and see if it'll boot into Linux off a live USB.

Sincerely,

 

me

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×