Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

AMD Ryzan 7 3700X w/ Asus Prime X570-P

CPU: AMD Ryzan 7 3700X

Motherboard: Asus Prime X570-P

Ram: Corsair Vengeance Pro 64GB (2x 32 GB) DDR4-3600

Storage: FireCuda 1 TB

Power: Corsair HX1000i

 

I just finished putting all the items in the case but when I was trying to get to the bios to start installing windows 10 pro. I could not get the boot window to come up. When the power switch is "on" on the power supply there is a light that turns "on" on the motherboard. Once power button is pushed on the case, the cpu fan and all case fan start spinning and ram lights up. The first thing that I tried was re seating everything. I pulled all the cables on both the motherboard and the power supply, nothing changed. Then I tried removing the SSD and all other case cables, no change.

 

Can someone please help I dont understand what is going on?

Link to post
Share on other sites

There is no iGPU in a 3700x, you will need a dedicated one. 

PC:

Spoiler

CPU: Ryzen 7 2700x | CPU Cooler: Hyper 212 Black | Motherboard: MSI B450 Tomahawk MAX | RAM: 2x16GB Corsair Vengeance LPX 3000MHz CL16 | Storage: Crucial MX500 500GB m.2, Crucial MX500 1TB 2.5" | GPU: Gigabyte RX 5700XT | Case: NZXT H510 | PSU: Corsair RM550x

788,303 PPD F@H

 

Peripherals:

Spoiler

Keyboard: Logitech G513 GX Browns | Mouse: Logitech G Pro Wireless | Monitors: Samsung TU7100 43" 4K HDR, 2 xAcer 28" 4K | Heaphones: Sony Platinum Wireless | Mic: Blue Yeti Nano

 

Link to post
Share on other sites

@gloop Since there is not integrated graphics will I need to put a graphics card in my computer first?

Link to post
Share on other sites
Just now, ttryon said:

@gloop Since there is not integrated graphics will I need to put a graphics card in my computer first?

Yes, you will need a graphics card. 

PC:

Spoiler

CPU: Ryzen 7 2700x | CPU Cooler: Hyper 212 Black | Motherboard: MSI B450 Tomahawk MAX | RAM: 2x16GB Corsair Vengeance LPX 3000MHz CL16 | Storage: Crucial MX500 500GB m.2, Crucial MX500 1TB 2.5" | GPU: Gigabyte RX 5700XT | Case: NZXT H510 | PSU: Corsair RM550x

788,303 PPD F@H

 

Peripherals:

Spoiler

Keyboard: Logitech G513 GX Browns | Mouse: Logitech G Pro Wireless | Monitors: Samsung TU7100 43" 4K HDR, 2 xAcer 28" 4K | Heaphones: Sony Platinum Wireless | Mic: Blue Yeti Nano

 

Link to post
Share on other sites

@gloop Thank you. Currently my graphics card is on back order so I will be waiting until then for that. Will I need to do anything with the GPU for it to work other that put in on the motherboard and plug in the power?

Link to post
Share on other sites
7 hours ago, ttryon said:

@gloop Thank you. Currently my graphics card is on back order so I will be waiting until then for that. Will I need to do anything with the GPU for it to work other that put in on the motherboard and plug in the power?

No, just plug he the power cables for the GPU and then plug in the display port/hdmi and you are good to go. 

PC:

Spoiler

CPU: Ryzen 7 2700x | CPU Cooler: Hyper 212 Black | Motherboard: MSI B450 Tomahawk MAX | RAM: 2x16GB Corsair Vengeance LPX 3000MHz CL16 | Storage: Crucial MX500 500GB m.2, Crucial MX500 1TB 2.5" | GPU: Gigabyte RX 5700XT | Case: NZXT H510 | PSU: Corsair RM550x

788,303 PPD F@H

 

Peripherals:

Spoiler

Keyboard: Logitech G513 GX Browns | Mouse: Logitech G Pro Wireless | Monitors: Samsung TU7100 43" 4K HDR, 2 xAcer 28" 4K | Heaphones: Sony Platinum Wireless | Mic: Blue Yeti Nano

 

Link to post
Share on other sites
  • 4 weeks later...

Im still have problems with it not posting. I now have a graphics card but now Im not getting a beep at all from the board. Im so confused.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×