Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Phoenix Ryzen Build

Hey everyone!

I'm a first timer all around; this is my first post here of my very first build also! I also have a minor issue with the build that I'm hoping someone can shed some light on. Though my general understanding is a bit on the novice side, due to the COVID pandemic I decided to take a leap of faith and leave a 10 year old career in food service to start studying IT, security, and programming, so any and all technical explanations are definitely welcome! haha
Enough intro, let's get to the build shall we!

I needed something that would serve as a primary workstation with a decent capacity for gaming (not a hardcore gamer but I do enjoy me games) so the specs are;


- Segotep Phoenix Case


- AMD Ryzen 5 3600 (Stock cooler)

- ROG Strix B450 F Gaming Board

- GSkill Trident Z RGB 16gb (2x8)

- Sapphire Pulse Radeon RX 5700 XT 8gb GDDR6

- (Aluminum Graphic Card Cooler 3x80mm fans - currently not installed till I can get a stable system.)

- Archer TX3000E TP-Link Wi-Fi 6.0
- Crucial 500gb m.2 NVMe SSD

- Seagate 500gb external SSD

- Corsair RM 750X PSU

- 3x Corsair AF120mm case fans

- 2x Magnetic RGB Strips


- Scepter 34" 21:9 100Hz monitor

- Redragon Shiva membrane keyboard

- Redragon M602 mouse


Super excited about it! Posted right away and no miss-plugs or connections! I actually added a slim GPU radiator on the second slot which you can see in the last build picture. When I tried re-starting the computer to boot the BIOS to tweak some settings, the components stayed active but the motherboard flashed the orange status LED and suddenly it wouldn't post... I was very careful to unplug the PSU, flush the residual charge, and got into it to make sure all connections were solid. Tried it again and it posted fine, so I went into BIOS, made my adjustments, and when I selected Save & Restart, the same issue once again... Did this dance a few times throughout the night trying to troubleshoot a faulty connection or something, ended up concluding that the GPU Radiator might be the problem, so I took that out and no difference... It will boot normally until you attempt a reset and then it won't post. Sleep and power function seem to be working fine, just the restart appears to cause this crash. My second uneducated thought was that maybe the restart function isn't working properly cause the case doesn't have a reset button, therefore I left the reset pins on the mobo unplugged, but I'm not sure if that would be causing the issue or not or how I could go about fixing it...

Once again, super excited to be part of this community! Thank you in advanced for your time if you stuck around and read this long post! All thoughts, comments & suggestions are welcome!








Link to post
Share on other sites

Awesome case and setup but I can't believe that case does not have a reset button.  I was under the idea that was standard in all cases now days.  And since you're aware of the heat, might want to consider putting a sink on your NVMe drive.  I have a 1TB Samsung 970 Evo Plus NVMe and a 2TB Samsung 960 Evo in my system and the NVMe drive runs right around 20 to 25 degrees hotter than the SSD.  I have a few items coming from Newegg and a sink for the NVMe is one of those items.


Good luck, take care, be safe, and have a nice weekend.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now