Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Mouse seems to be messing up my USB ports

messagetyper
 Share

I had just been moving my mouse, until all of the USB ports seemed to have turned themselves off for a few seconds.  And this happened because I moved the mouse by just a bit. Have been using another mouse and it's not problematic at all though, so I'm guessing the other mouse I have is really faulty right? Or could this be a problem with the power or something?

Link to comment
Share on other sites

Link to post
Share on other sites

25 minutes ago, messagetyper said:

I had just been moving my mouse, until all of the USB ports seemed to have turned themselves off for a few seconds.  And this happened because I moved the mouse by just a bit. Have been using another mouse and it's not problematic at all though, so I'm guessing the other mouse I have is really faulty right? Or could this be a problem with the power or something?

Occam’s razor says the old mouse.  Occam’s razor isn’t always right.

Life is like a bowl of chocolates: there are all these little crinkly paper cups everywhere.

Link to comment
Share on other sites

Link to post
Share on other sites

On 6/7/2020 at 9:51 PM, Bombastinator said:

Occam’s razor says the old mouse.  Occam’s razor isn’t always right.

Could be that my gaming mouse (the faulty one) is just straight up used and abused, unlike my cheap mouse which isn't as.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×