Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Throttlestop showing EDP current yellow under core and Ring

Go to solution Solved by unclewebb,

@vertexbrush - The PP0 Current Limit controls EDP OTHER throttling. The 4th Gen CPUs did not use IccMax which is why this option is grayed out.

 

Your current limit and power limits are both locked by the BIOS. There used to be a modified BIOS available for these laptops but there is not too much to gain by using it. Any increase in performance and you will be thermal throttling instead of power limit throttling.

 

The CPU core and cache offsets do not need to be set equally. If your 4700MQ runs stable with an undervolt of -107 mV, you are already doing quite well but you can try adjusting either of these further individually.

 

The default turbo ratios are 34, 33, 32, 32. To use any multipliers higher than this, you have to check the Overclock box or your request will be ignored. The max is 36, 35, 34, 34 when Overclock is checked since these CPUs support +2 bins of overclocking.

 

When using a Non Turbo Ratio of 1, there is no need to check the Set Multiplier option. Not checking this will free up a couple of CPU cycles.

 

If Power Limit throttling ever becomes an issue, I will teach you how to use the PowerCut feature. This tricks the CPU into reporting power consumption data way lower than actual power consumption so you can avoid power limit throttling all together.

 

 

Hello, First Post and I already need you help!
Can anyone help me with the issue shown below, both my limits in Throttlestop show EDP Current warning and I'm not sure what I should do to mitigate this
I have a Lenovo y510p with dual SLI Nvidia 755M graphics and Lenovo original 20v 8.5 amp output adapter
Running latest Windows 10
Edit: They occasionally flash red as well
image.png.fe035c17d16b0f8c214c1a0945bc4999.png

image.png.133bab3affb0d1e806c6fced170fc974.png

image.png.5030f6124472ec9b33dd3f3d0d38aa65.png

 

Link to comment
Share on other sites

Link to post
Share on other sites

It means you're at the limit of the current the VRMs can supply to the CPU.

That's set with Icc Max, which is greyed out for you so unless there is something in the BIOS which probably isn't the case you cannot change that.

F@H
Desktop: i7-5960X 4.4GHz, Noctua NH-D14, ASUS Rampage V, 32GB, RTX3080, 2TB SX8200Pro, 2x16TB Ironwolf RAID0, Corsair HX1200, Thermaltake Overseer RX1, Samsung 4K curved 49" TV, 23" secondary, Mountain Everest Max

Mobile SFF rig: i9-9900K, Noctua NH-L9i, Asrock Z390 Phantom ITX-AC, 32GB, GTX1070, 2x1TB SX8200Pro RAID0, 2x5TB 2.5" HDD RAID0, Athena 500W Flex (Noctua fan), Custom 4.7l 3D printed case

 

Dell XPS 2 in 1 2019, 32GB, 1TB, 4K

 

GPD Win 2

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks Kilrah, I have the stock Bios provided by lenovo which is the latest, but that was about 5 years ago. And that doesn't give much options in the way of overclocking or changing voltages

Link to comment
Share on other sites

Link to post
Share on other sites

@vertexbrush - The PP0 Current Limit controls EDP OTHER throttling. The 4th Gen CPUs did not use IccMax which is why this option is grayed out.

 

Your current limit and power limits are both locked by the BIOS. There used to be a modified BIOS available for these laptops but there is not too much to gain by using it. Any increase in performance and you will be thermal throttling instead of power limit throttling.

 

The CPU core and cache offsets do not need to be set equally. If your 4700MQ runs stable with an undervolt of -107 mV, you are already doing quite well but you can try adjusting either of these further individually.

 

The default turbo ratios are 34, 33, 32, 32. To use any multipliers higher than this, you have to check the Overclock box or your request will be ignored. The max is 36, 35, 34, 34 when Overclock is checked since these CPUs support +2 bins of overclocking.

 

When using a Non Turbo Ratio of 1, there is no need to check the Set Multiplier option. Not checking this will free up a couple of CPU cycles.

 

If Power Limit throttling ever becomes an issue, I will teach you how to use the PowerCut feature. This tricks the CPU into reporting power consumption data way lower than actual power consumption so you can avoid power limit throttling all together.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

@unclewebb Hi, I was really hoping you would reply since I've seen somewhere you were working with a similar setup yourself, sorry for replying late as I was busy with some freelance work. I went ahead and did the modifications you mentioned although I didn't mess around with the CPU Core voltage as i had come to a sweetspot before but with the overclocking box unchecked I think I'll have to redo it again since you said it was being ignored up until now.
Also mentioning if it makes any difference, I use my laptop as a stationary unit, as in without the battery (it died a log time ago) and hooked directly to the adapter which in-turn is hooked to a APC UPS 1100 VA
 

On 6/6/2020 at 4:05 AM, unclewebb said:

If Power Limit throttling ever becomes an issue, I will teach you how to use the PowerCut feature. This tricks the CPU into reporting power consumption data way lower than actual power consumption so you can avoid power limit throttling all together.

Please Teach me, I love learning new things :)

Also does turning off speedstep give any sort of performance improvement? or is it just healthy for the cpu to keep it on so that it can power down when not needed?. because since i dont sport a battery i dont think ill need any of those powersaving features?
Also I'd like your advice on if its a goodtime to invest on a new setup? Do you think its worth it or can i still squeeze some juice from my 6+ year old rig? I do a lot of photoshop and Occasional 3D like Blender and Zbrush

image.png.cb3daff62ba9ea6ed8acb2074deff10d.pngimage.png.21aaecddf8c01147186f9d5c6372a43d.png

 

Edit: The EDP current issue has gone away :D , The only two changes I did was uncheck the Set Multiplier and check the overclock as you've suggested. I don't know which one did it but I'm grateful! will check the stability in the coming few days and report back! :)

 image.png.be904fd53fd0090f27b7074cacb60d32.png

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×