Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

VR - Random Frame Skips

I bought a Valve Index headset and installed everything properly. Using a RTX 2080ti and a water cooled and slightly overclocked i9-7960x I have more than enough for simple VR games on low settings. 

The rendering is smooth in every game, even Half Life Alyx at Ultra settings. 

 

However, there are these very distinct frame skippings occurring randomly with around 8-10 seconds intervals. They doesn't seem to be related to any CPU bottlenecks or GPU problems, both being at 12% and 40% in Steam Home.

I've tried seeing any correlation between software jumping up in use in the activity monitor when the spike occurs, but nothing shows. I've tried all possible combination of settings in the NVidia settings and no luck.

 

Looking at the advance frame timing graph in SteamVR I can see that the "WaitGetPoses" drops entirely when the spike goes up for everything else. The "WaitGetPoses" has to do with the position of the headset, but I can't figure out if this is how the computer and software is handling and sending that data (out) or if this is before the computer and software handles the data (in).

 

I've looked around and seen that some Unity developers seem to have similar problems, but there are no consistent answers to any of this while the "reinstall windows 10" standard answers are the most common non-answers. I think that figuring out why this thing is happening is preferable before jumping to a solution.

 

Anyone else who experience this thing? 

 

 

AfterTrack3.thumb.png.8d43e7850f1c6df1eedbadd04c87ea8b.pngAfterTrack.thumb.png.eaebc096757cbbb2f55db963913457ac.png

 

 

 

Link to post
Share on other sites

SIMPLE VR ON LOW SETTINGS?!?! that is one of the best possible cards you can find.

Regarding your problem it is likely to be be just a driver issue, or windows 10 being on crack

Main PC [The Rig of Theseus]:

CPU: i5-8600k@5.0GHz | GPU 1: GTX 1660@2070MHz | GPU 2: GT 710 | RAM: 16 GB DDR4 3000MHz | Case: Lian Li PC-O11 Dynamic | PSU: Corsair RM 650i | SSD: Corsair MP510 480GB |  HDD: 2x 2TB WD Black | Motherboard: Gigabyte Z390 Aorus Pro | OS: Windows 10 Pro

 

Secondary PC [Why did I bother]:

CPU: AMD Athlon 3000G | GPU: Vega 3 iGPU | RAM: 8 GB DDR4 3000MHz | Case: Corsair 88R | PSU: Corsair VS650 | SSD: WD Green M.2 SATA 120 GB | Motherboard: MSI A320M-A PRO MAX | OS: Windows 10 Pro

 

Server [Solution in search of a problem]:

Model: HP DL360e Gen8 | CPU: 1x Xeon E5-2430L v1 | RAM: 12 GB DDR3 1066MHz | SSD: Kingston A400 120GB | OS: Debian Buster

 

Server 2 electric boogaloo [A waste of electricity]:

Model: intel NUC NUC5CPYH | CPU: Celeron N3050 | RAM: 2GB DDR3L 1600MHz | SSD: Kingston UV400 120GB | OS: Debian Buster

 

Laptop [A hunk of shit]:

Model: MacBook Air Late 2010 | CPU: Core 2 Duo L9600 | RAM: 4 GB DDR3 1066MHz | OS: MacOS Catalina 

 

Photography:

 

Cameras:

Full Frame digital: Sony α7

APS-C digital: Sony α100

Medium Format Film: Kodak Junior SIX-20

35mm Film:

 

Lenses:

Sony SAL-1870 18-70mm ƒ/3.5-5.6 

Sony SAL-75300 75-300mm ƒ/4.5-5.6

 

 

PSA: No, I didn't waste all that money on computers, (except the main one) my server cost $40, the intel NUC was my old PC (although then it had 8GB of ram, I gave the bigger stick of ram to a person who really needed it), my laptop is used and the second PC is really cheap.

I like tinkering with computers and have a personal hatred towards phones and everything they represent (I daily drive an iPhone 7, or a 6, depends on which one works that day)

Link to post
Share on other sites
4 minutes ago, mbntr said:

SIMPLE VR ON LOW SETTINGS?!?! that is one of the best possible cards you can find.

Yeah, which is my point. The card is one of the best cards and the processor isn't the worst for gaming and within a very simple rendered environment, like the grid/mountain loading screen for SteamVR, which gets the timing of the GPU down to 0,4, you still get these hiccups from "WaitGetPoses".

 

Since everyone supposedly are on the same drivers for SteamVR and Nvidia, it would be interesting to hear the frame timing others have. This is an issue that can be hard to spot when just casually playing, but it's glaring in slower things and if you notice a large purple spike in the in-headset graph it's that thing.

Link to post
Share on other sites

Try and play once without the OC on the CPU. Had weird Frame issues when overclocking the 8600K i had in the past.

Dislaimer: If my post is older than 5 minutes, refresh the page. Most of my posts get edited straight away. 😄

 

PSU Tier List          AMD Motherboard Tier List          SSD Tier List

 

Current Specs:

CPU: AMD Ryzen 5 5600X - Motherboard: ASUS ROG Strix B550-E - GPU: PNY RTX 3080 XLR8 Epic-X - RAM: 4x8GB (32GB) G.Skill TridentZ RGB 3600MHz CL16 - PSU: Corsair RMx (2018) 850W - Storage: 500 GB Corsair MP600 (Boot) + 2 TB Sabrent Rocket Q (Storage) - Cooling: EK, HW Labs & Alphacool custom loop - Case: Lian-Li PC O11 Dynamic - Fans: 6x Noctua NF-A12x25 - AMP/DAC: FiiO K5 Pro - OS: Windows 10 Pro - Monitor: LG 27GN950-B - TV: LG C9 OLED 55" - Speakers: Samsung HW-Q80R + optional surround speakers - Mouse: Logitech G Pro + Powerplay - Keyboard: Logitech G915, Corsair K63 Wireless + Lapboard - Headphones: Beyerdynamic Amiron Home - Microphone: Antlion ModMic

 

Temperatures @steady state: Furmark + CinebenchR23 running for 1 hour. Fans @850RPM. Pump @1600RPM.

Water: 37°C

CPU: 73°C

GPU: 54°C

Link to post
Share on other sites
38 minutes ago, Stahlmann98 said:

Try and play once without the OC on the CPU. Had weird Frame issues when overclocking the 8600K i had in the past.

Unfortunately I have and it's not that.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×