Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

G920 is detected in wrong mode [FIXED]

IamSnix
 Share

Hey everyone!

During the last hours I tried to get my G920 running again. Unfortunately without any success...

 

The problem is, as far as I could find out through my research, that the G920 is detected in Xbox mode and does not install the correct drivers.

 

I think I have gone through all available solutions without producing any change in the situation.

 

The things I have already tried:

  • G HUB reinstalled several times
  • Manual uninstallation of all Logitech relevant files
  • Manual cleaning of the registry entries as far as possible
  • Multiple reboot
  • Rollback to older LGS software
  • Manual installation of the .inf drivers
  • I also tried the WheelDriverCleaner.exe

The only feedback I get from the G920 is rapidly flashing Light above the Xbox button. I have to say that I have no more ideas at the moment...

 

The most frustrating part of the problem is that the g920 had already worked in a previous Windows installation, and seems to be fully functional on my second computer.

 

One thing that struck me as odd is that when I start my computer the steering wheel calibrates as usual, but as soon as Windows starts booting, the calibration process stops immediately and appears to have been turned off.

 

Maybe some of you have one or two more ideas...

Link to comment
Share on other sites

Link to post
Share on other sites

Just wanted to let you know I fixed the problem. 

I have broken down the driver installation to the smallest detail and found out that the driver dc1-controller was faulty. This driver is actually responsible for Xbox One controllers but the driver of the G920 needs this driver for its own installation.

I have tried everything to repair the dc1-controller driver but without success. The last option was to reset Windows. This was successful. Immediately after completing the Windows installation I could connect the G920 and it was recognized immediately.

Afterwards I could install G Hub without any further problems.
Link to comment
Share on other sites

Link to post
Share on other sites

  • 7 months later...

hello bro i got the same issue.. but i don't know what i should do.. i restart my win too but don't work.. can you help me.. follow me on instagram pls to send you the a videoclip.. (@eduardalex)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×