Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Asus ROG Strix G (Laptop screen) - laptop model: G531 GV


Hello everyone,

So, I have an odd question, normally, someone would ask, why is my screen not running at the proposed screen refresh rate, and their screen will be running lower than it should.

Mine runs at - 150Hz instead of 120Hz, I got such an "update" overnight, I tried adding custom resolution with 1+ Hz than 120Hz (the refresh rate my screen shipped with), and it didn't work, I guess I typed in 150 and it worked, so 1920x1080 150p Hz appeared in my resolutions, I don't know why, but apart from 120 Hz and 48Hz being able to be added in the custom resolutions, 150 is the only one that can be added as a custom resolution, for other refresh rates, it says something in the lines of -"exceeds Maximum bandwidth capacity".

I tested 120Hz and 150Hz, and just moving the mouse feels smoother, I am 99% sure that it isn't a placebo effect. But that 1%...

Everywhere I could check, it says 1920x1080p@150Hz or something similar, the formatting isn't always the same. So, what would be the only reason for Intel Graphics Control Panel to allow me to add only the 150Hz, but none of the resolutions from 121-149, 150 can be added, and after 150 none can't be added.

Can someone over here answer my question, and also tell me if something like this can be used safely, can I leave it at 150Hz?





Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now