Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

HELP😖 Game won't launch 😞😫😵

So I've had this problem for a while now, basically when I go to play monster hunter world the game won't launch, steam says its running but nothing happens except my cursor starts flashing as if its loading constantly, I have looked in task manager and I can see to instances of windows problem reporting happening. 

 

I have tried deleting and reinstalling the game twice now and I have verified the game files. 

 

I'm really stuck now please help. 

Link to comment
Share on other sites

Link to post
Share on other sites

Well have you tinkered with the Steam folder where the Game is installed in ? Maybe let that download finish up that is running in the background on Steam there. Last resort would be to completely uninstall and reinstall Steam. 

Make sure to Quote or mention me @soldier_ph if you want me to see your reply or Content such as Status Updates, Threads, Album entries or Blog Posts.

 

You can take a look at all of the Tech that I own and have owned over the years in my About Me section and on my Profile.

 

Where I was Mentioned: 

Mentioned in 5.8.2020 Techlinked

Mentioned in 8.8.2020 Techlinked

Mentioned in 11.3.2021 Techlinked

Link to comment
Share on other sites

Link to post
Share on other sites

I am not familiar with this game but a lot of games need .dotnet framework libraries to launch.

Make sure you have the latest one installed (get it from microsoft.com).

Also if something is broken, Steam has a repair functionality to check the install directory for issues. 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Fatneckitten123 said:

No luck, any other suggestions? 

 

Please remember to quote the user you are trying to reply to otherwise they will not see your reply. If all  of your drivers are up to date, bios, graphics, chipset, and windows. I'd recommend doing an in-place upgrade on Windows, that is where you download the Windows 10 Media Creation Tool from Microsoft's website, run it and do the upgrade option follow the steps and make sure to keep files and apps. It will essentially reinstall Windows without getting rid of any files or programs. If the in-place upgrade doesn't work then it may be an issue specifically with MHW and you'll need to contact their support.

Main Desktop: CPU - I9-9900k @5ghz | Mobo - Gigabyte Z390 Aorus Master | GPU - Asus ROG STRIX RTX 3090 Gaming OC RAM - G.Skill Trident Z RGB 32GB 3200mhz | AIO - H150i Pro XT | PSU - Evga 850 GQ | Case - Phanteks P500A Digital - White | Storage - Samsung 970 Pro M.2 NVME SSD 512GB / Sabrent Rocket 1TB Nvme / Samsung 860 Evo Pro 500GB / Samsung 970 EVO Plus 2tb Nvme |

 

TV Streaming PC: Intel Nuc CPU - i7 8th Gen | RAM - 16GB DDR4 2666mhz | Storage - 256GB WD Black M.2 NVME SSD |

 

Phone: Samsung Galaxy S20+ 5G - Deep Black 512GB |

 

If you ask for a Mid Tower case recommend, I will 90% of the time recommend the Fractal Design Meshify C or S2.

Link to comment
Share on other sites

Link to post
Share on other sites

@SpookyCitrus

Tried the reinstall windows with the media tool and still have the same problem, any more ideas? 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Validate Gamefiles doesnt help?

CPU i7 6700k MB  MSI Z170A Pro Carbon GPU Zotac GTX980Ti amp!extreme RAM 16GB DDR4 Corsair Vengeance 3k CASE Corsair 760T PSU Corsair RM750i MOUSE Logitech G9x KB Logitech G910 HS Sennheiser GSP 500 SC Asus Xonar 7.1 MONITOR Acer Predator xb270hu Storage 1x1TB + 2x500GB Samsung 7200U/m - 2x500GB SSD Samsung 850EVO

Link to comment
Share on other sites

Link to post
Share on other sites

  • 11 months later...

Any updates on this issue? Got the same problem.

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, f32csd3sd said:

Any updates on this issue? Got the same problem.

i had this issue on my laptop,when the game  loaded  and u don't see anything press alt+enter

 

ill just hope for op's sake they figured that out too 🤷

AMD stands for Advanced Micro Machines

-ColdFusion, 2021

Link to comment
Share on other sites

Link to post
Share on other sites

In the past i've had this happen on Tera and Lineage 2 and usually it was a .Net issue. Complete uninstall of all dotNet components, complete uninstall of the game and then clean install again of the game, with it getting whatever it needs.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×