Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Top PCIe slot stopped working after shutting my pc down

Hello and thank you for taking the time to read this. 

 

I am using an i5 4690k in an asrock z87 extreme4 with a gtx 980ti.

 Last night after a normal day I shut down my PC like always. I shut off the power strip and today I want to start up my PC and no display. After some troubleshooting and swapping GPUs I found that the Top PCIe slot isn't working.

I put a 2nd gpu (gtx 970) and nothing.

I put the 970 in the 2nd pcie slot and all is good. (My 980ti is too long to fit). Is there anything I can do or do I need a new MB? Thanks. 

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, GreY2231 said:

Hello and thank you for taking the time to read this. 

 

I am using an i5 4690k in an asrock z87 extreme4 with a gtx 980ti.

 Last night after a normal day I shut down my PC like always. I shut off the power strip and today I want to start up my PC and no display. After some troubleshooting and swapping GPUs I found that the Top PCIe slot isn't working.

I put a 2nd gpu (gtx 970) and nothing.

I put the 970 in the 2nd pcie slot and all is good. (My 980ti is too long to fit). Is there anything I can do or do I need a new MB? Thanks. 

Make sure there isn't any burnt spots on it and that everything is clean

PC: Motherboard: ASUS B550M TUF-Plus, CPU: Ryzen 3 3100, CPU Cooler: Arctic Freezer 34, GPU: GIGABYTE WindForce GTX1650S, RAM: HyperX Fury RGB 2x8GB 3200 CL16, Case, CoolerMaster MB311L ARGB, Boot Drive: 250GB MX500, Game Drive: WD Blue 1TB 7200RPM HDD.

 

Peripherals: GK61 (Optical Gateron Red) with Mistel White/Orange keycaps, Logitech G102 (Purple), BitWit Ensemble Grey Deskpad. 

 

Audio: Logitech G432, Moondrop Starfield, Mic: Razer Siren Mini (White).

 

Phone: Pixel 3a (Purple-ish).

 

Build Log: 

Link to comment
Share on other sites

Link to post
Share on other sites

27 minutes ago, GreY2231 said:

Hello and thank you for taking the time to read this. 

 

I am using an i5 4690k in an asrock z87 extreme4 with a gtx 980ti.

 Last night after a normal day I shut down my PC like always. I shut off the power strip and today I want to start up my PC and no display. After some troubleshooting and swapping GPUs I found that the Top PCIe slot isn't working.

I put a 2nd gpu (gtx 970) and nothing.

I put the 970 in the 2nd pcie slot and all is good. (My 980ti is too long to fit). Is there anything I can do or do I need a new MB? Thanks. 

 

Could you take a picture of the motherboard and around the PCIe slot and attach to this thread, also what power supply are you using?

Hope this information post was helpful  ?,

        @Boomwebsearch 

Link to comment
Share on other sites

Link to post
Share on other sites

Everything was perfectly fine. I repeated the cpu and all was good. Weird 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×