Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

HELP!! low ping high latency high packet loss

hey so i have recently gotten my first desktop and i go to play some games and bam! the games are super laggy and damn near impossible to play so i go onto speedtest.net and check my ping and speeds and i have all around great numbers, so i turn on the latency tracker in game and i will go from 32ms to 1000+ms, this is consistent across all games and i even did some things in command prompt to see packet loss and i get 100% drop rate. I use a wired connection and am baffled at what to do next, any ideas?

(i know this video is super low quality but here are some examples of the lag https://youtu.be/5aWR84FF1S4 )

speedtest.PNG

Link to comment
Share on other sites

Link to post
Share on other sites

Try activated UPnP in your router.

Its possible your provider has issues as well.

 

CPU i7 6700k MB  MSI Z170A Pro Carbon GPU Zotac GTX980Ti amp!extreme RAM 16GB DDR4 Corsair Vengeance 3k CASE Corsair 760T PSU Corsair RM750i MOUSE Logitech G9x KB Logitech G910 HS Sennheiser GSP 500 SC Asus Xonar 7.1 MONITOR Acer Predator xb270hu Storage 1x1TB + 2x500GB Samsung 7200U/m - 2x500GB SSD Samsung 850EVO

Link to comment
Share on other sites

Link to post
Share on other sites

33 minutes ago, Praesi said:

Try activated UPnP in your router.

Its possible your provider has issues as well.

 

thanks i did a little more research and when doing a long test i would get random spikes from lets say 50ms to 200-300ms so i think a little more is going on than what i thought, thanks for your suggestion it is much appreciated

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×