Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Everything Turns Off But My Motherboard

So i spent quite some time building this PC and when i got my last part i built it together now i’m fairly new and haven’t built a pc since sophomore year HS so i did my best after all the plugs were in the correct spots i booted the PC up and it turned on for a good 5 seconds then everything shut down and my motherboard stayed on still... then it would just flicker on and off but still the motherboard stays on... i have 0 idea what i’m doing wrong all these parts are brand new so i have no clue if a part could be defective or something isn’t plugged in right. 

5020F041-8BF5-4DD4-91F3-805A3A03A830.jpeg

E7BBBE31-9C8D-4079-ACB3-CAB1E478B922.jpeg

68FA9416-43FC-4EA4-B396-BD78DBB8337D.jpeg

Link to comment
Share on other sites

Link to post
Share on other sites

oh and btw don’t be makin fun of my cable management i haven’t even bothered perfecting it i was just moving things to the right spot first lmao

Link to comment
Share on other sites

Link to post
Share on other sites

Your pc never truly turns off, it keeps power flowing for things like the clock.

CPU: Intel core i7-8086K Case: CORSAIR Crystal 570X RGB CPU Cooler: Corsair Hydro Series H150i PRO RGB Storage: Samsung 980 Pro - 2TB NVMe SSD PSU: EVGA 1000 GQ, 80+ GOLD 1000W, Semi Modular GPU: EVGA 02G-P4 GeForce GT 1030 RAM: Corsair Dominator Platinum 32GB (2 x 16GB) DDR4 3200mhz Motherboard: Asus ROG STRIX Z370-E Gaming

Link to comment
Share on other sites

Link to post
Share on other sites

well why did everything shut off but the motherboard

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×