Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

RX Cards No Computer Bios Access

Cbanter
 Share

Hey guys, so I discovered something today that I wish I knew a long time ago and I just wanted to see what more I could learn about it. I was building up a Dell t3500 and put an RX 560 in it. No matter what I tried and checked, I could not go into the computer's bios anymore and it would just go to a black screen. Put in an Nvidia card and no issues like usual. I found out that a lot of these cards only support UEFI bios. However, I'm able to run it just fine in Windows and even did a userbenchmark test on it. Why in the world won't this card and others I have tried from AMD work properly with a Legacy BIOS computer? And why would it fully work inside windows but not allow me to access the BIOS screen?

DSC_0816.JPG

Screenshot_20200510-123155.png

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×