Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC Turning on for one second then turning off

Spook142
 Share

I just bought a i9-9900KF, put it in, and it turns off a second after booting. To see if it was something shorting out or something else I swapped it for my previous CPU, a i7 - 7700k, it worked just fine.
I had originally thought that maybe it wasn't getting enough power (I have a 750w) but doing a quick google search I found out they have similar power consumption.

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, Spook142 said:

I just bought a i9-9900KF, put it in, and it turns off a second after booting. To see if it was something shorting out or something else I swapped it for my previous CPU, a i7 - 7700k, it worked just fine.
I had originally thought that maybe it wasn't getting enough power (I have a 750w) but doing a quick google search I found out they have similar power consumption.

What make/model of motherboard are you using?

 

Is the CPU cooler attached properly and plugged in with new thermal compound.

Link to comment
Share on other sites

Link to post
Share on other sites

Aorus Z270X Gaming K7, and I made sure to apply thermal paste

Link to comment
Share on other sites

Link to post
Share on other sites

Oh, thank you very much.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×